Running rich

Results 1 to 5 of 5

Thread: Running rich

  1. #1
    My First Supra suprapokemon's Avatar
    Join Date
    Mar 2014
    Location
    Kingsport Tn.
    Posts
    84

    Running rich

    I just got done with a engine swap on my 82 p-type I put the 5mge from my 83 in it and I upgraded my intake to a 85 with the D ports. I knocked out the freeze plug and plummed in my IAC valve so my car will idle I know the engine didn't run rich in my other car and I used the 83 injectors and fuel rail plus regulator. I did have to remove my TPS from the 82 intake to the 85 how do I set the TPS and could it cause my engine to run rich and not want to idle well when cold?

  2. Remove Advertisements
    CelicaSupra.com
    Advertisements

  3. #2
    CelicaSupra.com Member supkar's Avatar
    Join Date
    Mar 2005
    Location
    Santa Cruz, Ca. 95061
    Posts
    3,907
    This is a bit confusing. More details about what you swapped in. I guess you played with the ISCV-----not the IAC, whatever that is.
    You probably should have swapped the 82 throttle body over, not just the TPS
    83-Red P-type , 6M,. LJM strut-bar, RC intake,Thorley header,Tenzo 17" wheels, cross-drilled rotors, Eibach springs, KYB shocks, 85 hatch and int., 82 header panel=Frankenkar

    87 4 Runner, White, 22RE, 302K on original motor, still strong

    "This car is so loud , I heard you before I saw you!" said the nice policeman. Hidden Content

  4. #3
    My First Supra suprapokemon's Avatar
    Join Date
    Mar 2014
    Location
    Kingsport Tn.
    Posts
    84
    Same this I Idle A air C control and I just spelt out valve so IAC valve same as the iscv

  5. Remove Advertisements
    CelicaSupra.com
    Advertisements

  6. #4
    CelicaSupra.com Member ddd228's Avatar
    Join Date
    May 2005
    Location
    N. Seattle.
    Posts
    4,386
    You may have a temp sensor that is WAY out of specs or corroded contacts or is disconnected.
    The ECU takes readings of what up with the engine when warm or cold.
    I wonder if the '82 ECU is not happy with the '83 engine controls. Including the '85 TPS.!!!!!
    BTW,all of cars run on the rich side and that's a good thing.
    Franken KAR.
    Dave in Seattle. I keep LATE hours.Hidden Content
    '84 type "L" ,Auto ,daily driver. Dk blue.

  7. #5
    My First Supra suprapokemon's Avatar
    Join Date
    Mar 2014
    Location
    Kingsport Tn.
    Posts
    84
    The problem was all my computer. I had it loose because I was doing some wiring above it and I didn't know it grounded threw the base and I left it loose for a couple days while drive so it shorted it's self out. Put a new one in and is perfectly fine now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts