ma67lovers's 7m-gte build **56k Death** - Page 11

Page 11 of 11 FirstFirst ... 91011
Results 101 to 106 of 106
  1. #101
    CelicaSupra.com Member gamble's Avatar
    Join Date
    Feb 2004
    Location
    Austin, TX
    Posts
    2,779
    Those look great, i think Manvir is running them as well... or maybe his are another 16" mesh available new on the cheaper end of the scale. Let us know how those tires end up treating you.

  2. Remove Advertisements
    CelicaSupra.com
    Advertisements

  3. #102
    CelicaSupra.com Member ma67 lover's Avatar
    Join Date
    Apr 2008
    Location
    missoula montana
    Posts
    1,350
    Well as always with building cars its one step forward and two steps back. Having a little fueling issue. I have a gigantic fuel pump yet not getting much fuel... 340LPH AEM pump yet the first prime only gets me to 8 psi, next crank to 12, ect.... So I might have crushed a fuel line installing my motor and trans. Going to check that out here soon. Worst comes to worst I will get a fuel cell! Could be worse, right?
    ~William Macy~
    82' fresh paint 7mgte
    What am I doing Hidden Content
    What kind of oil should Hidden Content
    Hidden Content Hidden Content

  4. #103
    CelicaSupra.com Member gamble's Avatar
    Join Date
    Feb 2004
    Location
    Austin, TX
    Posts
    2,779
    How is the pump wired? That monster of a pump may not be getting the power it needs and is just sort of chugging along. You can do a volt drop test on it easily enough, that would rule out power/ground to it so you can go on to the physical aspects of it.

  5. Remove Advertisements
    CelicaSupra.com
    Advertisements

  6. #104
    CelicaSupra.com Member ma67 lover's Avatar
    Join Date
    Apr 2008
    Location
    missoula montana
    Posts
    1,350
    HAH.... so found the issue.... AEM provided a check valve so when you prime it the pump holds the pressure. Its an O ring fitting to 8an and the check valve was stuck/faulty. Pulled my entire fuel system apart and couldn't find a single issue. Thought I would check the check valve for blockage and the needle wasn't moving very easily in it. I couldn't even blow through it at all. Pulled the guts out of the check valve and she started right up. AEM is going to warrenty the valve and ship me a new one, so all is good.

    She runs great now! Takes a couple extra cranks to get her started without the check valve but ain't no thang!

    Photos to share for the moment!






    Full tune @ 18lbs tonight if my knock sensors permit! More to come
    ~William Macy~
    82' fresh paint 7mgte
    What am I doing Hidden Content
    What kind of oil should Hidden Content
    Hidden Content Hidden Content

  7. #105
    Whistles racerxj220's Avatar
    Join Date
    Aug 2006
    Location
    Alabama
    Posts
    573
    Epic build, William. Glad to see you got it running right, and happy to hear AEM is standing by their product.
    Built 1JZ-GTE, PTE 6466, PGS Dog Box R-154, Pro-EFI 128, Nitrous, Flex Fuel, Headgames "R" cylinder head, SPF1 manifold, Hypertune, so much more...
    1983 Supra
    Jeffrey Rainwater

  8. #106
    CelicaSupra.com Member ma67 lover's Avatar
    Join Date
    Apr 2008
    Location
    missoula montana
    Posts
    1,350
    Quote Originally Posted by racerxj220 View Post
    Epic build, William. Glad to see you got it running right, and happy to hear AEM is standing by their product.
    Yeah for sure, they rock and are really great at customer service! Now I just need some skid videos! Hopefully sooner than later
    ~William Macy~
    82' fresh paint 7mgte
    What am I doing Hidden Content
    What kind of oil should Hidden Content
    Hidden Content Hidden Content

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts