CLToy 1984 P-Type Restoration... - Page 31

Page 31 of 31 FirstFirst ... 21293031
Results 301 to 302 of 302
  1. #301
    CelicaSupra.com Member CLToy's Avatar
    Join Date
    Oct 2005
    Location
    Charleston, WV
    Posts
    2,116
    Quote Originally Posted by Saul68 View Post
    Nice work !What kind of gauges are you using ?
    AEM digital....
    - AFR and boost on the a pillar for now
    - water temp, oil pressure, and oil temp above the radio
    - gps on column
    -more planned ..... want differential readings but keep that quiet for now. :-)

    More detailed images and install earlier in this thread
    Chadrick
    Hidden Content ; Hidden Content ; Hidden Content ; Hidden Content ; Hidden Content ; Hidden Content ; 2007 Tundra CrewMax TRD Supercharged; Hidden Content ; 1967 VW Beetle (Her Classic)
    Hidden Content

  2. Remove Advertisements
    CelicaSupra.com
    Advertisements

  3. #302
    CelicaSupra.com Member CLToy's Avatar
    Join Date
    Oct 2005
    Location
    Charleston, WV
    Posts
    2,116
    I installed the w58 elbow and speedo cable. Unfortunately the speedo still doesn't work. I will check at the back of the cluster...maybe there is a problem there. If that's not it, maybe there is something wrong with the gear in the transmission.
    Chadrick
    Hidden Content ; Hidden Content ; Hidden Content ; Hidden Content ; Hidden Content ; Hidden Content ; 2007 Tundra CrewMax TRD Supercharged; Hidden Content ; 1967 VW Beetle (Her Classic)
    Hidden Content

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts