WTB: Front Wiper Motor

Results 1 to 4 of 4
  1. #1
    CelicaSupra.com Member mtymseharmer's Avatar
    Join Date
    Oct 2013
    Location
    United States
    Posts
    136

    WTB: Front Wiper Motor

    as the title says, I'm looking for a working front wiper motor for my 82 p-type.
    1982 P-Type with 1UZFE swap - "DedPewl"

  2. Remove Advertisements
    CelicaSupra.com
    Advertisements

  3. #2
    CelicaSupra.com Member ddd228's Avatar
    Join Date
    May 2005
    Location
    N. Seattle.
    Posts
    5,077
    Holy Shiza! Expensive.
    https://www.napaonline.com/en/search...Qualified=true
    Now,I see why you want a used one.
    Do....NOT buy an A-1 Cardone rebuild.
    Dave in Seattle. I keep LATE hours.Hidden Content
    '84 type "L" ,Auto ,daily driver. Dk blue.

  4. #3
    CelicaSupra.com Member 4SFED's Avatar
    Join Date
    Jul 2003
    Location
    E. Chugabrew, Wisconsin
    Posts
    5,451
    Double check that it's the motor that's dead and not the transmission. I've seen a few over the years that did not work but when I pulled out and tested the motor it worked fine when I bench tested it. Oftentimes it's the round plastic piece that ties the motor to the wiper linkage that wears out - the motor is actually turning but the wipers aren't.
    Actually you don't have to pull the motor to test it - disconnect the electrical connector for the wiper and jumper 12v from the battery to pin 2 and put ground to the motor body and if it's still good, the motor should turn slow speed, or to pin 1 and ground for fast speed.

    edit: BTW, if you see a wiper motor for sale that supposedly fits all Celica sub-models, it won't fit the Celica Supra. Celica Supra motor is different from Celica even though I've seen them listed as one size fits all.
    I have a used one for sale - $65 plus shipping
    Last edited by 4SFED; 07-16-2019 at 06:57 PM.
    Dave Harrison

    current lineup and year acquired:

    '85 white Mark2 7mgte 5sp 1988
    '85 white Mark2 7mgte Auto 2009
    '84 maroon Mark2 6mge 5sp 2013
    '86 red Mark2 7mgte 5sp 2016
    '85 black Mark2 6m Frankenmotor 5sp 2017

  5. Remove Advertisements
    CelicaSupra.com
    Advertisements

  6. #4
    CelicaSupra.com Member mtymseharmer's Avatar
    Join Date
    Oct 2013
    Location
    United States
    Posts
    136
    Quote Originally Posted by 4SFED View Post
    Double check that it's the motor that's dead and not the transmission. I've seen a few over the years that did not work but when I pulled out and tested the motor it worked fine when I bench tested it. Oftentimes it's the round plastic piece that ties the motor to the wiper linkage that wears out - the motor is actually turning but the wipers aren't.
    Actually you don't have to pull the motor to test it - disconnect the electrical connector for the wiper and jumper 12v from the battery to pin 2 and put ground to the motor body and if it's still good, the motor should turn slow speed, or to pin 1 and ground for fast speed.

    edit: BTW, if you see a wiper motor for sale that supposedly fits all Celica sub-models, it won't fit the Celica Supra. Celica Supra motor is different from Celica even though I've seen them listed as one size fits all.
    I have a used one for sale - $65 plus shipping
    It was for sure the motor as I did test it on my bench and nothing. I ended up finding one specifically for a Celica supra on eBay. Thanks!
    1982 P-Type with 1UZFE swap - "DedPewl"

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts