Really loud squeal from vicinity of power steering pump on starting engine

Results 1 to 5 of 5
  1. #1
    CelicaSupra.com Member
    Join Date
    Sep 2011
    Location
    Monroe Township, New Jersey
    Posts
    226

    Really loud squeal from vicinity of power steering pump on starting engine

    I could hardly steer the car and it made all kinds of serious sounds so I replaced the power steering pump with a reman unit from my local auto parts store(not a national chain like AutoZone or Pep Boys). Now when I start up there is a very loud squeal that lasts anywhere from 30 seconds to two or three minutes. I have been squirting belt dressing on it, and it seems to have gotten somewhat less, but still persists. Is the pump bad, or do I have the belt too loose or too tight? HELP!!!!

    Thanks, Bob

  2. Remove Advertisements
    CelicaSupra.com
    Advertisements

  3. #2
    CelicaSupra.com Member ddd228's Avatar
    Join Date
    May 2005
    Location
    N. Seattle.
    Posts
    5,192
    Your car had "morning sickness".
    The spool valves inside the R&P are stuck/clogged.
    When warmed up,the aluminum expands and works normally.
    The PS system has no "filter" as such so particles collect at the valves and make it inoperable.
    The rack is full of poop. Best to change it out.
    This condition was very common with early GM cars and I have replaced a few.
    There are inline filters for the PS system.
    Maybe this is the one:
    https://www.ebay.com/itm/Remanufactu...kAAOSw9YdcxoXP
    https://www.napaonline.com/en/search...Qualified=true
    $50 core charge.
    Dave in Seattle. I keep LATE hours.Hidden Content
    '84 type "L" ,Auto ,daily driver. Dk blue.

  4. #3
    CelicaSupra.com Member Supradavis's Avatar
    Join Date
    Mar 2004
    Location
    Mesa, AZ
    Posts
    1,431
    When you replaced the pump, did you spray/clean out the fluid reservoir? There is a screen inside that can get clogged with years of muck. A good spray out with brake cleaner and compressed air usually does the trick. And I would say you need to tighten the belt. Also check the tightness of the bolts/nuts for the brackets that hold the alternator and power steering pump. Mine were a bit loose when I replaced both units on my car, and made it impossible to get the proper tension on the belt!

    And you shouldn't ever need to spray "belt dressing" on your belts. It's not a salad, ya know!
    Dave K.
    '92T - 346 rwhp / 441 rwtq
    '86P x2 - Hidden Content
    Hidden Content
    Admin - AZSupras.com

  5. Remove Advertisements
    CelicaSupra.com
    Advertisements

  6. #4
    CelicaSupra.com Member
    Join Date
    Sep 2011
    Location
    Monroe Township, New Jersey
    Posts
    226
    Thanks guys. Yes, I cleaned out the reservoir well. I am inclined to agree with Dave in any case, as I had already considered changing the rack, but I have had the car off the road for so long I would like to enjoy it for a while before it sits on jack stands for another long period of time.

    Thanks for the observations; I guess a new rack is in my future. Mayhap I will just let the guys at the shop do it, as that way it will get done much sooner.

  7. #5
    CelicaSupra.com Member ddd228's Avatar
    Join Date
    May 2005
    Location
    N. Seattle.
    Posts
    5,192
    I would NOT have a clue to flush out the R&P at all. I have never had one apart to see what's up.
    Our shop just replaced them with a flushing system.
    PS: the R&P manufacturers will NOT warranty a rack or a PS pump under certain conditions.
    Some pumps and racks may come with an in line filter.Rich (Save Tacoma)recommends them.

    My system does not have one,but I do flush mine out(And make a mess),every few years, with ATF +4.
    Damn,it's stinky stuff!
    IF I ever replaced mine, I would attack it with my pressure washer B-4 I pulled it out:Once at the self-serve car wash and once more in my driveway.
    A $50 core is OK,but I would buy one with the outer tie rods already in place. I want BLUE ones! I trust NAPA parts. Not A-1 Cardone ones ,at all.Moog?
    Dave in Seattle. I keep LATE hours.Hidden Content
    '84 type "L" ,Auto ,daily driver. Dk blue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts