Digi-Dash and the 7MGTE

Results 1 to 3 of 3
  1. #1
    CelicaSupra.com Member nnywg's Avatar
    Join Date
    Jul 2010
    Location
    Calgary
    Posts
    482

    Digi-Dash and the 7MGTE

    I researched this extensively on the site, but never found an answer. My long-running 7MGTE swap/restoration is out on the streets again as of this weekend. I have the typical MSD adapter wired in, but my RPM is reading way low on the Digi-Dash. I would estimate about half of what it really is based on my ear vs. what the gauge is reading.

    Any advice from the old sages on here?
    WTB: Nose Emblem

  2. Remove Advertisements
    CelicaSupra.com
    Advertisements

  3. #2
    CelicaSupra.com Member SupraFiend's Avatar
    Join Date
    Mar 2003
    Location
    Vancouver, BC
    Posts
    10,162
    Where is the adapter mounted? There are known to have short lifespans. The one I mounted in a buddies 1jzgte swap, we stuck under the hood in the path of a cold air supply. So far so good.
    Black 86 mk2 Project Car
    New SDR 86 mk2 Daily User, Highway Cruiser AND Parking Lot Abuser in the works!

  4. #3
    CelicaSupra.com Member nnywg's Avatar
    Join Date
    Jul 2010
    Location
    Calgary
    Posts
    482
    It's right by the fuse box. Basically new, I'd be a bit surprised if it somehow cooked itself already. And clearly some signal is coming through.

    Idle for example reads about 400rpm. The throttle holds open slightly without physically lifting up on gas pedal. Sounds like 1200-1500 but reads 700-800. Wastegate dumping letting off the gas at when it reads 1000rpm.

    Will try to take it for a spin tomorrow and record speed / gear / rpm readout, maybe I'm crazy.
    WTB: Nose Emblem

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts