Toyota Celica Supra Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Brand new to this thread, also a brand new owner of an 84 Supra. The only problem with the car is that it won't start. The previous owner says he was washing out the engine bay because it was sitting for a couple of months and was dirty, when he went to start it thought it wouldn't fully start. He thought the problem may be that the fuel pump or filter stopped working while it was sitting or stopped because of an electrical failure while he was washing inside. So I went to buy the relay that controls the fuel systems and replaced it but that didn't change anything so I ruled that out. I am going to replace the pump and filter tomorrow but wanted to know if there might be anything else that is inhibiting it to start. Any help is appreciated, thank you.
 

·
Registered
Joined
·
14 Posts
Brand new to this thread, also a brand new owner of an 84 Supra. The only problem with the car is that it won't start. The previous owner says he was washing out the engine bay because it was sitting for a couple of months and was dirty, when he went to start it thought it wouldn't fully start. He thought the problem may be that the fuel pump or filter stopped working while it was sitting or stopped because of an electrical failure while he was washing inside. So I went to buy the relay that controls the fuel systems and replaced it but that didn't change anything so I ruled that out. I am going to replace the pump and filter tomorrow but wanted to know if there might be anything else that is inhibiting it to start. Any help is appreciated, thank you.
There is a test plug near the air flow meter at the back of the air box, jumping the terminals will make the fuel pump run with ignition on - if you hear it in the tank then the pump is good.

With that out of the way, my bet is on ignition system; get an old spark plug and pull the center wire off the distributor cap. Put that end on the spark plug terminal then ground the body of the spark plug somehow. Have someone crank the engine over and watch for spark - if yes then do the same with one wire coming out of the distributor to eliminate cap and rotor. If no spark occurs at all, inspect all wiring from distributor to coil for any breaks then proceed to test the coil itself. Oe Ohm specs for the coil can be found online with a basic search.
 

·
Premium Member
Joined
·
8,219 Posts
Check for spark?
EFI fuse under the hood
Power circuit breaker in the drivers foot well, use a paper clip to reset.

Check for fuel, jump the connector at the AFM to determine if you can hear the fuel pump working or not as stated above...
 
  • Like
Reactions: SantoryuSamurai

·
Registered
Joined
·
4,181 Posts
Washing the engine bay? With water? That explains a lot.
 
  • Like
Reactions: SantoryuSamurai

·
Registered
Joined
·
14 Posts
Washing the engine bay? With water? That explains a lot.
To be fair; I recently did it with mine... but i am rescuing a rats nest and had to blast a bunch of cactus needles out of the engine bay. I also made sure to not soak certain components. It runs after some extensive fuel system cleaning.
 

·
Registered
Joined
·
274 Posts
Did you remove distributer cap and see if there's any moisture under cap.
Remove plug wires from plugs and check for water around plugs.
 

·
Registered
Joined
·
4,181 Posts
I rarely use water, but when I do I carefully wrap plastic bags around the dizzy, ignitor, AFM , ect
 

·
Premium Member
Joined
·
6,168 Posts
If you run the engine during the engine wash, you will KNOW when you aimed water into the wrong area, when the engine dies.
Besides, It's much easier to see what you are doing when the cooling fan blows away the under hood mist.
 

·
Registered
Joined
·
4 Posts
I second water around the plugs. I washed mine once and had the same issue . The plugs sit in a recessed channel on the top of the engine, it’s easy for water to migrate down into the holes and cause misfires on affected cylinders.
 

·
Registered
Joined
·
96 Posts
I've had my Supra since '96, and used a pressure washer countless times in the engine room. Squeaky clean - never any issues. (I blow away excess water, though..)
But water may sneak past the grommets, so just pull them out and see!
The distributor is on its side, so water could easily get trapped in there as well.
 

·
Premium Member
Joined
·
6,168 Posts
Gee, water in and around the spark plugs causes the engine to shut off. Well, that is inconvenient! Look at how the 2 JZ dealt with that issue and how clean it looks!
Some similar cover can be made like this:
16922


Wait a minute! That engine is WAY different!
One thing that I want to point out about the engine shutting OFF with water intrusion:
It's not really the water that causes the problem it is the DIRTY water that allows the spark to go to ground. Water is just a fair conductor dirty water with carbon and oily dirt is much better.
There are some REALLY crafty people on this forum!
A FFIM for a 5MGE or an intake manifold to fit DCOE Weber carburetors? An amazing amount of ingenuity!
'Sparkie' covers would take some eyeballing time to figure out. Plastic, alloy or what ever. Bolt on, press fit or attach with magnets to seal it up a little better.
CAD mold could be done in a larger 3D printer of heat-resistant plastic. I was thinking flat sheet metal that is semi-sealed.
It has to look COOL!
All of those wires..

Throttle linkage....

This idea was mine, I think:
Pretty simple oil splash guard. Reduces cam cover leaks.
 
1 - 11 of 11 Posts
Top