Toyota Celica Supra Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter · #1 ·
I just got a question for you people. The parts car that i got ('84 MKII) has an 5M-E engine (SOHC) with 142 hp. How many MKIIs did come with these engines, and in which countries were they sold/not sold? Did these models come in the US?


Just wondering :)
 

·
Registered
Joined
·
78 Posts
I'm pretty sure they only came in Australia/New Zealand with the 5M-E. Maybe Japan.
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #3 ·
Jeff Lange said:
I'm pretty sure they only came in Australia/New Zealand with the 5M-E. Maybe Japan.
The parts car was new in sweden. They were sold new with 5M-E engines. Hmmmm. :?:
 

·
Registered
Joined
·
78 Posts
Okay, so I guess some of Europe got the 5M-E too ;)... All I know is that Canada didn't for sure, and I'm pretty sure the US didn't.
 

·
Registered
Joined
·
351 Posts
My MKI came with one.... had only 115 horses though. I ditched it for the 5M-GE, swap was very strait forward!
 

·
Registered
Joined
·
9,445 Posts
Okay......

The AUS 84 - 85 MKII's had the 5ME. Remember, AUS did not get any 82 - 83 MKII's, unless someone imported in a CelicaXX from Japan.

Am pretty sure that NZ did not get the 5ME, I believe they got the 5MGE (am trying to recall all of our discussions we had w/ Jonathan when we were still on the Yahoo list). I know for sure they got the 1G GA60's.

USA: The only time a 5ME appeard on a Supra, was on the 81 MKI MA47 (79 - 80's had the 4ME, 82+ had the 5MGE). I "believe" the 81 + 82 MX Cressida's also had the 5ME.

Sweden & 1 other European country (forgot who it was now, it's not Germany or the United Kingdom) had the 5ME's.

Am pretty sure Japan did not get the 5ME on their early 82's, but I could be wrong on this. I'm almost pretty sure they got the 5MGE. Anyone got a 82 Japan brochure handy???

HTH.
 

·
Registered
Joined
·
78 Posts
Yeah, we got the 5M-E in 81 here. I figured we were only talking about the MKII ;)
 

·
Premium Member
Joined
·
1,361 Posts
Hey All,

I am here to shed some light why some MA61s were fitted with a 5M-E instead of the 5M-GE.

In Australia at the time we were running Leaded and Premium Leaded Petrol at the time. We did not get unleaded petrol till 1986 thus most of the cars in Australia were leaded motors and that the MA61 was fitted with a 5M-E...

That is most probibly why MA61s fitted with a 5M-E was countries still running Leaded Petrol.

As for New Zealand... They are the destination of all Japanese condemed cars as the Japanese have to change their car every X amount of years. Thus some cars in NZ were originally driven around Japan.

PS. Oxygen Sensors and Leaded Petrol are not best friends.

Correct me if I am wrong.

Cheers
 

·
Registered
Joined
·
185 Posts
ZZT231 said:
In Australia at the time we were running Leaded and Premium Leaded Petrol at the time. We did not get unleaded petrol till 1986 thus most of the cars in Australia were leaded motors and that the MA61 was fitted with a 5M-E...

That is most probibly why MA61s fitted with a 5M-E was countries still running Leaded Petrol.
I've seen 5M-GE equipped MKII's without cat / oxygensensor to be used with leaded fuel. For example Finnish and Saudi-Arabian versions. (170hp non-TCCS)

Here in Sweden (and Switzerland, dunno 'bout you Aussies :)) we had quite strict emission laws at the time & leaded fuel, hence the 5M-E which has provisions for the "thermactor" system. ("air injection" before the exhaust header)
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #11 ·
Thanks all. That clears up my question.


Söta bror :p ! I didnt know there were any swedes on this forum. Wheehee. Where in sweden are you from Hemiyoda?


(opti - who now realises that he is not only sourounded by supra-mad americans. Swedes has joined in the ranks as well)
 
1 - 11 of 11 Posts
Top