Toyota Celica Supra Forum banner

21 - 32 of 32 Posts

·
Registered
Joined
·
2,406 Posts
Wondering if I need to do this. I was driving the 83 home today, and braked to stop for a traffic light, and the charge and brake indicator lights flashed on and off. Was running fogs, headlights, and heater at that time. It doesn't do it all the time, just randomly. The car is an 83 with a 6MGE, so the engine does have the multi rib belt pulley system. I changed the alternator less than a year ago, and figured I would have to do the mod, but the lights never came on, so I didn't change anything. So almost a year later, I am starting to get this random flash of the indicator lights, hope it's not a bad alternator again, because if so, I'll be looking to go with something else if I have to change it again (either a 7mge, or Camry alternator) because the alternator issues are getting old.
 

·
Super Moderator
Joined
·
10,395 Posts
Most of the time, if you don't have a newer style alternator, this means your alt is dead or dying. However I've noticed that the charge relay in these early cars is prone to failure. I thought I had a bad alt in my 82 DD, but the relay had failed. It was REALLY tough to find a good one too. I would stock pile these things people, that or convert to the later alts and wiring.
 

·
Registered
Joined
·
905 Posts
For the record, could someone confirm the correct placement of the diode in Figure 2 below?
The original drawing from Dave Shepherd does not align on my screen so I would like to double check where it goes.

Anode goes to? A, B, C, or D?
Cathode goes to? A, B, C, or D?


Anode is the unmarked end
Cathode is the end with the silver stripe

As per bdewitt760 the proper orientation is:
Anode (Unmarked End) into A
Cathode (Silver Striped End) into B

http://www.user.dccnet.com/zezula/AltUGPic1.jpg

Figure 1. The Driver Side Kick Panel Fuse Box with the Charge Light Relay installed.

http://www.user.dccnet.com/zezula/AltUGPic2.jpg

Figure 2. The connector on the fuse box with the Relay pulled and the 4 contacts showing.

This is just such a great nugget of information I want to make sure I install it correctly.

Thanks
 

·
Registered
Joined
·
4 Posts
I am so glad I joined this forum. I was plagued by this alternator light problem for the past 7 years and finally gave up. Can this problem also kill my battery life over time?


This solution worked!! Both lights now are off. My cruise works again and I could not be happier. Best $5 I ever spent.

Black side into A (top left) and striped side into B(top right)




Sent from my iPad using Tapatalk HD
 

·
Registered
Joined
·
3,006 Posts
Where can I pick one if these up? Auto zone or Orielly's doesn't carry them
Any electronics supply house. But probably the most convenient place for you is Radio Shack, though some of the staff may not know what you are talking about being mostly cell phone salemen.
 

·
Registered
Joined
·
2,406 Posts
If you have a 82 or 83 and change out your alternator to anything newer. You will have a problem
You've got that right. When I bought the 83 with the 6M in it, I had no issue because the previous owner was still using an 83 alternator on the 6m, so everything was cool until that alternator failed. I think they used locktite for shafts to put the 85 pulley on the 83 alternator because it would not come off. I got an 85 alternator for it, and the problems began. Not sure how many fusible links I burnt up (always the yellow one). Once I changed the fusible link, everything would be fine for a while, and eventually it would burn up again. It finally got to the point that once I replaced the link, the indicator lights would stay on giving the impression that the alternator failed, but the charge relay was the part that actually failed. I went out today, and did the charge light mod, and everything seems to be ok (no indicator lights, system is charging, and no hot fusible link) we'll see how she goes.

If I were to ever give someone tips on a 6m swap into an 82 or 83, I would not leave this mod out of the discussion.

Thanks for the thread, very valuable information!!!
 

·
Registered
Joined
·
598 Posts
This thread was very informative thanks to all who posted this great info!
 

·
Registered
Joined
·
483 Posts
This thread got my charge light to turn off, my emergency brake light to turn off, and made my cruise control work again. I'd been living with it for years since I put the CS130 alternator in my car.
 
21 - 32 of 32 Posts
Top