Toyota Celica Supra Forum banner

1 - 6 of 6 Posts
G

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I have a near perfect 82 Supra. the 82's had 4 vacuum switchs near the thermostat. I have been looking for a working White 3 port vacuum switch part number 25810-43010. I have managed to get my hands on at least 8 of them and none of them work. does anyone know of a source for good vacuum switchs or a work around to get my car running properly. thanks any help is greatly appricated.
 

·
Registered
Joined
·
2,297 Posts
Hmmm...

That avatar looks vaguely familiar...I can't quite put my finger on it though....
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #3
What can I say

I have a mint condition Terra Cotta 82 and liked the Avatar.
 

·
Registered
Joined
·
2,297 Posts
Re: What can I say

George Blair said:
I have a mint condition Terra Cotta 82 and liked the Avatar.
Just giving you a bad time George. Glad you like the avatar ;)
 

·
Registered
Joined
·
4,871 Posts
George,
Do you have emissions inspection in your area? The vacuum hose routing and VSV's are a spaghetti nightmare on the 82, as I'm sure you already know. :? I still have the vacuum hose diagram that you sent me, but without knowing how each VSV operates and when, it's hard to tell just what controls what, and when. Do you have a copy of the 82 TSRM? If so, your best bet might be to check each VSV for proper operation by consulting the VSV test procedures in the TSRM.
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #6
Dave:
Yes we do have emissions testing here in Arizona. No, I do not have a copy of the TSRM. I have used my Haynes manual to test a lot of the items on the engine. to test the BVSV I checked it with the engine cold and again with the engine at operating temperature. there was no change in the state of the vacuum switch. I have tried around eight of the white vacuum switch's and haven't found one that will change states when I go from ice water to a pan of boiling water on the stove. Currently I have a black three port BVSV in place of the white one and have reversed vacuum lines 3 and 6. The car seem to run better once i build some RPM's but i still have some of the lag coming off idle. My long term fix it to upgrade to an 87 or 88 engine with Turbo. I am currently looking for a donor car. Do not konw how long this process is going to take and would like to fix the problem in the mean time. Thanks for you interest in helping.
 
1 - 6 of 6 Posts
Top