Toyota Celica Supra Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
85 L type - 6mge. It runs great when cold then after about 5 mins it stalls like it is out of gas. My mechanic swears its not the fuel pump because he says it is still pumping when the car stalls. I have replaced the fuel filter, plugs, wires. distributer, etc.

The car will not start again until cold.
 

·
Registered
Joined
·
794 Posts
Will it start (or try to start) if you shoot starting fluid in the intake?

If it starts or try's to start then you have a fuel delivery issue. If you are sure the pump is pumping (it is really quiet because it is in the tank) then check your fuel filter.

If it doesnt then you have ignition issues. Pull a sparkplug and ground it on the block or head and see if it gets spark when you turn it over. Sometimes when an ignition coil is going bad it will only run when cold. Could also be a cap or rotor but probably not.

Good Luck.
 

·
Super Moderator
Joined
·
8,413 Posts
I'd have the mechanic test the fuel pressure. This is the only sure way to eliminate the fuel pump as the problem. Electric fuel pumps tend to be flakey when they are going out. If the pump doesn't put out enough pressure the engine won't run right.
 

·
Registered
Joined
·
7,111 Posts
jschoffer said:
85 L type - 6mge. It runs great when cold then after about 5 mins it stalls like it is out of gas. My mechanic swears its not the fuel pump because he says it is still pumping when the car stalls. I have replaced the fuel filter, plugs, wires. distributer, etc.

The car will not start again until cold.
I had the same problem with my car in October. I changed the fuel filter thinking it was that, but it was my fuel pump that went bad

Kinda off topic, But

I dont think there where any 85 L-types? :?
 

·
Registered
Joined
·
9,445 Posts
Uh, yes, there were 85 L-Types... Every so often when you read discussions about those 15 x 6" wheels??? Those are the 85 L-Type wheels.

Back on topic..... At this point, I'm also thinking ignition problems here as well. Sounds like the ignitor is on it's way out.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #7
It was the fuel pump

It was the fuel pump. The pressure was fluctuating badly. Where is the best place to purchase one?
 
1 - 7 of 7 Posts
Top