Toyota Celica Supra Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
126 Posts
Discussion Starter #1
Ok, I have 3 mkii.
This one has been giving problems since it got home. It got issues dam it.
Since the day I got it, it has been sitting there. I tried all I can and still come out short. I am not going to bore you of what has been done. I am going to tell you what is wrong with it now. Here it goes..
It starts right up idle smooth when warm. I slowlllly rev up or speed to about 65. It speeds up like a mopad pulling 5000 lbs weight. I did the injectors, fuel pump and filter, timing, tps, and afm. I thinking of bypass the wire of the tps straight to the ecu. And the same with the afm. Ideas please.
thanks!
 

·
Registered
Joined
·
29 Posts
Sounds like spark plugs / wires to me. If the car has no power maybe some plugs aren't firing. Do you get sudden bursts of power when driving? When you drive it for about 10 minutes, get out and look under the car. If your cat is glowing orange or just insanely hot and you smell gas, this could mean you need new plugs and/or wires. That happened to me too and it was the plugs.
 

·
Registered
Joined
·
591 Posts
checked cam timing or ignition timing? my car did that too. my cams were a notch behind the crankshaft(mechanics erroe bigtime) and seems to be kinda common on cars that had the belt done by someone who doesn't know now much of a pain in the ass these belts are. just turn the crank til the little nick in it is at the 0 mark for the ignition timing and take off the top timing cover and see if the notches line up. if they aren't perfectly lighned up you need to fix the timing. AFTER that check your ignition timing. the person that did mine didn't reset the distributor timing until i had to replace my dist. the timing was severely retarded because of the cams being retarded. after all that my car got about 4 times the power it had.

and unless you are hauling way over the reccomended limit on your car it should only be about 3000-3200lbs. the cressida weighs in at 3600 and the supra is smaller(lighter). that or a cast iron frame;)
 

·
Registered
Joined
·
126 Posts
Discussion Starter #4
Thanks guys!
JuiCe
I didnt look at the converter, but the exhaust manifold is red hot.
DKJones96
(checked cam timing or ignition timing)
Do you mean take the valve's covers out and make sure you see oil hole .
I heard someone said that you can advance or retard the cam timing. Can someone please explain?
thanks!
 

·
Registered
Joined
·
29 Posts
If the exhaust manifold is getting red hot, this might mean you're not burning off all of the gas being used and it's going straight through to the exhaust. I would definitely at least check your plugs and wires. If the plug tips are gunked up or burnt, replace them all. Also have someone start your car for you while you look at the plug wires. Quit possibly there could be a break in the insulation of one of your wires and the spark is arching to a grounded piece of metal. Just a longshot, but who knows.
 

·
Registered User
Joined
·
3,283 Posts
I didn't see where anyone mentioned a plugged cat. That'll get things real hot real fast.

Good luck,

Mike
 

·
Registered
Joined
·
191 Posts
mwebber said:
I didn't see where anyone mentioned a plugged cat. That'll get things real hot real fast.

Good luck,

Mike
I agree....
 

·
Registered
Joined
·
29 Posts
Good call! I completely forgot about that. That also happened to me. The honeycomb was actually broken up and the screens were out of place, so I was getting no power. I took the cat off and beat the hell out of the insides with a breaker bar to hollow it out. Just a temporary fix due to those damn emissions tests :roll:
 
1 - 8 of 8 Posts
Top