Toyota Celica Supra Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
245 Posts
Discussion Starter #1
Guys i was riding by a local used car dealer and low and behold a SUPRA!!!! an 86 to be exact. so i went to inquire about it. they want $200 but it does not start up all the way. When i try and crank it it just turns over. i swear it almost wants to start. but does not. my 86 5spd did the same thing one time and it was the timing belt. could this be the same problem. the mechanic there told me it was one of 3 modules but they were not going to geuss which one. and i did not want to take the timing belt cover off to see if it was bad or not right in front of him. any help would be great. sorry if i posted this in the wrong section.


jeremy (who was happy to see another supra in town!!!!)
 

·
Registered
Joined
·
245 Posts
Discussion Starter #3
i am thinking the timing belt. the mechanics working at this palce are not to bright. i do not even think they have checked the timing belt. the cover looks as though it has been there for a while. it has spark, but i am not sure about the fuel. how do i check for that? if you are asking does it have gas then yes. 1/2 tank.

jeremy
 

·
Registered
Joined
·
4 Posts
i meant if there was fuel transfer to the engine, but nvmd that. remove the timing belt cover to check the "teeth" on the belt. one easy way to check for fuel..crank the car(engine), then remove one of the spark plugs to see if it is wet or smells like gas.
 

·
Registered
Joined
·
245 Posts
Discussion Starter #5
ok so i pumped the gas a little and she starts to turn over more. i keep doing this and she started right up. i also think there is something wrong with the gas needle. when i was there the other day it had 1/2 tank but now the gas light is on. but it stayed up and running. seems to be idleing high. could i have a bad fuel filter? or something clogged in the line? do auto's squat down when shifted into drive? Never owned an auto so i am not sure if that is supposed to happen. and i bought it for 250 from the owner. will try to post some pics when i get it home.



jeremy
 

·
Registered
Joined
·
245 Posts
Discussion Starter #7
so is that normal?
 

·
Registered
Joined
·
4,871 Posts
The squatting is normal with an auto trans.. The same thing happens if you let the clutch out on a 5-speed car with it in gear and the E-brake on.
 

·
Registered
Joined
·
3,271 Posts
it's all about weight transfer and such... loading the drivetrain.

i did that today in the '82... got it started and let out the clutch forgetting it was in gear. oh well.
 

·
Registered
Joined
·
245 Posts
Discussion Starter #11
1 - 11 of 11 Posts
Top