Toyota Celica Supra Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
591 Posts
Discussion Starter · #1 ·
in normal mode my transmission acts really stupid. if i have the gas down over half way it'll go okay in first then abruptly shift. disengage the lokc-up clutch then reengage it again. it does that in every gear. at less throttle openeing in normal or at the same throttle openeing in power mode it's fine just hard acceleration in normal does it suck like that. makes the car feel kinda cheap.
 

·
Registered
Joined
·
3,433 Posts
whats your fluid like? if its dirty can cause issues, i don't know if it will cause that, and also you may want to check ur kickdown cable see if it needs adjusted......... hope that helps a little
 

·
Registered
Joined
·
796 Posts
Not sure which year has an electronic controlled auto, could be all years, could be none. But if the two suggestions above don't fix it, I'd bet its that.
I don't own an auto, so I'm really not familiar with them, but I recall something about an extra ecu or computer control box for the automatic tranny.
In any case, I'd do the two other things first as they aren't nearly as expensive as replacing electronics!
Good luck!
 

·
Registered
Joined
·
43 Posts
i'd be willing to bet its the tranny fluid...bad trannly fluid in auto's can make em run like total shit cuz the fluid does a lot

it makes the hydraulic pressure to shift, it locks up the torque converter, it does it all

so yea, change that out (maybe even toss in some nice synthetic stuff and be nice to ur tranny) and see how it shifts, should be a lot closer to mmmm butter haha
 

·
Registered
Joined
·
591 Posts
Discussion Starter · #5 ·
well it has been flushed it's nice and full of toyota t-IV transmission fluid. but it's always done that. like in normal mode toyota didn't program it to shift right under hard acceleration. and it gives some real kicks sometimes in normal mode if i surge the gas. but in power mode it shifts beautifully no matter where the throttle is. it's so smooth most of the time the only way to tell it's shifted is the engines speed drops. and it's the same with slower acceleration in normal mode... i think it's just stupid lol

oh and floored in normal mode is faster in my car then going in power mode cuz i loose ALL power above 5.3k i'm pretty sure it's valvesprings tho.
 

·
Banned
Joined
·
1,314 Posts
Its cause you are revving it in neutral really high and then dropping it into gear. Really bad! your torque converter has sh*t the bed. Sorry to tell ya man. Next time dont do the rev and drop. I did the same thing to my camry(my first car i didnt know any better). Anyways the car was mint and an old lady drove it never broke it loose. So i get ahold of it. Slam gears in it and a year later the car is toast. Did the reverse into drive to peel out, Rev in neutral really high and drop the gears.....HORRIBLE, not good for the transmission. Thats why you have no power. You need a new torque converter. Im done ranting.
 
1 - 6 of 6 Posts
Top