Toyota Celica Supra Forum banner

21 - 40 of 44 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #21
so my car is now running after all !
heres a pic of how it looks now.
have alot of ideas of what to do next but not sure where to start..:woot:

maybe flares then, bondo work then a DIY paintjob..
im getting a new exhaust soon too, and i want it to have a high pitch sound like a lambo or rarri or sumn v10"ishh.. im not sure how i can accomplish that or a similiar sound.. i might just go 3" and start from there in addition to my kinda beat magnaflow muffler.hmm..

i can post an idle/rev video if anyone is interested. ?
 

·
Registered
Joined
·
58 Posts
Discussion Starter #22
any suggestions on ecu's??
and/or experience with them (2jzge only, nonvvti preferrably)?
i want to get a stock M/T sc300/mk4 one but not sure if itll fix the air flow prob.
aem and megasquirt make a pnp standalone which looks amazing and itll be cool to delete my maf so i dont have to worry about that thing.., but itll be a while before i can get that.. $$$
not sure if i would go piggyback..
anyways.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #24
Honestly just happy this thing is still kickin around. Not really many jz experts around here. If it runs well leave it alone IMO.


My friend who got this thing wired up is a JZ expert so, because of his magic and skill, this is now my main daily..leaving the Mazda5 at home most of the time now ahahah
I want an ecu cuz im not sure how to fix my maf problem, or MAF related problem that makes this thing unable to use more than 50% throttle. Anyways, it reaches freeway speeds pretty zippy so I can't complain too much. Hopefully I figure out the problem before getting the standalone, although having a 2 step tune would be awesome. ..
 

·
Registered
Joined
·
790 Posts
Are you hitting soft rev? what ECU are you running? What codes are you throwing if any?

I have a 93 GS300 2jzge swapped car with the stock auto trans ecu running fine with no soft rev limiter or any issues. swapping to another ECU might not fix your problem
 

·
Registered
Joined
·
58 Posts
Discussion Starter #26
Are you hitting soft rev? what ECU are you running? What codes are you throwing if any?

I have a 93 GS300 2jzge swapped car with the stock auto trans ecu running fine with no soft rev limiter or any issues. swapping to another ECU might not fix your problem

What is soft Rev?? Overall, it cuts out around 3k..i just let off the gas and push it again and it miggggght work it's way up to 3500 but at that point I'm kinda already going at a nice speed...kinda ducks getting onto freeways though looool. Any ideas if not an ecu? What about an M/T one?
 

·
Premium Member
Joined
·
725 Posts
It's the first of two rev limiters, works like limp mode, limits your revs if the engine thinks something is wrong, like bad sensors for example.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #28
It's the first of two rev limiters, works like limp mode, limits your revs if the engine thinks something is wrong, like bad sensors for example.

How do I get rid of both limp modes?? Btw the neutral safety switch pins (two of them) are both un-pinned, I'm not sure if I need to re-pin them and splice them together.. But I reeeeeally need a solution to get rid of this soft Rev, any ideas or helpful hints?
 

·
Registered
Joined
·
15,003 Posts
Check your engine codes and report back which codes it is throwing. The ECU will literally tell you whats wrong.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #30
Looks like it was not limp mode, just a cheeeeezy cone filter adapter gasket.
car runs great now!! , but I have high idle and cannot find the leak with brake/TB cleaner... I gotta do the smoke test on it soon to alleviate it.
glad I didn't get an ecu in hopes to fix the problem lol , but I will switch to an M/T ecu later in the future..
These cars handle well with NA power ((;

also picked up a sweet, not-to-shabby , not sure if it helps rear strut bar for cheap..apparently the guy is an MK2 head...i guess he has a black mk2 on ssr sp1's iunnoo..
 

·
Registered
Joined
·
15,003 Posts
I wouldnt trust those tiny bolts as a seat harness anchor.
 

·
Registered
Joined
·
12 Posts
i need help lol I'm new to the mk2 supra culture and I want to do a 2jzge. but i dont know exactly what I'm going to need to swap from a 5mge to a 2jzge. thanks for your time
 

·
Registered
Joined
·
1,638 Posts
There is a FAQ in the top of this section that covers a 2JZGTE swap in quite a bit of detail. This is a good place to start for you. There is a 2JZGE wiring write up as well. Please take the time to read and then ask more specific detailed questions for us to help you. Preferably in your own thread.
In short you need a 2JZGE engine, W58 will work if you can get the bellhousing, and wiring. Those are the basics. Most everything is covered in the FAQs.

i need help lol I'm new to the mk2 supra culture and I want to do a 2jzge. but i dont know exactly what I'm going to need to swap from a 5mge to a 2jzge. thanks for your time
 

·
Registered
Joined
·
58 Posts
Discussion Starter #38
I wouldnt trust those tiny bolts as a seat harness anchor.
would weld in, but not sure yet. does help with stability tho. picked it up bc it is one of a kind. (;
and my harness is taken out, just put it in there to see how it felt in my car tbh
 

·
Registered
Joined
·
58 Posts
Discussion Starter #40
awh man, all the pictures following the build arent up anymore..looks like the image host took them down. heres how my supra sits now
#2jznoshit ! lol
viewpoint1.jpg
 
21 - 40 of 44 Posts
Top