Toyota Celica Supra Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,539 Posts
Discussion Starter · #1 ·
Hey Supra folks,

I've gotten a couple of emails from a newbie Supra owner in Virginia Beach VA who just bought an 85 Supra. He's having some problems with it (sounds like fuel rail/injectors related) and is looking for some help/expertise/parts. There's no way I can diagnose his problems by email, so I'm wondering if anyone close to him would be willing to help him out?
If so, please send me a PM and I'll put you in touch with him.

Thanks a lot guys and gals.
 

·
Registered
Joined
·
2,476 Posts
I'll stick my answer here so Jay can see it. Jay is in VA Beach and is very knowledgable. I beleive his handle is 3000ccMKII.
 

·
Registered
Joined
·
1,108 Posts
Muchbzy said:
I'll stick my answer here so Jay can see it. Jay is in VA Beach and is very knowledgable. I beleive his handle is 3000ccMKII.

<-------- THAT's ME.....

Dean I have sent you a PM of my number and just tell the guy to call me by this weekend so that I can schedule his car this weekend for me to take a look at...

JAY

BTW... Cee-Jay thanks for the 6M manifold
 

·
Registered
Joined
·
2,476 Posts
3000cc MK2 said:
Muchbzy said:
I'll stick my answer here so Jay can see it. Jay is in VA Beach and is very knowledgable. I beleive his handle is 3000ccMKII.

<-------- THAT's ME.....

Dean I have sent you a PM of my number and just tell the guy to call me by this weekend so that I can schedule his car this weekend for me to take a look at...

JAY

BTW... Cee-Jay thanks for the 6M manifold
Not a problem.
 

·
Registered
Joined
·
1,108 Posts
Dean said:
Thanks a lot Jay.
I've sent your number to Jason. Hopefully you can get together and figure out what is going on with his Supra.
Dean,

I have seen Jason's car and here is what I have found out so far...
The car is sputtering when you press on the gas... really bad on 4000 rpm below and has a slight sputter but not noticeable at higher rpms...
The car idle fine but when I was inspecting the, the exhaust has a slight miss on the exhaust pulsation...
I inspected the plugs and it was full of oil... I saw the old head and it was nasty as hell... full of oil dipposites and the plugs are full of burnt oil...

I still have to do a compression test on the cylinders but I am guessing the fouling of the is due to a bad rings or bad stem seals... I am guessing too that the old head.

I am guessing the fouling of the plugs is the cause of the heasitation and sputtering whline incresing the RPM's

what do you think??? I still have to do some more investigating cause it was late and I have to go to work that night but I will give him a call so that we could do a compression test.

JAY
 
1 - 6 of 6 Posts
Top