Toyota Celica Supra Forum banner

1 - 20 of 35 Posts

·
Registered
Joined
·
837 Posts
Discussion Starter · #1 ·
ok so i just rebuilt the 5mge in my 84 mk2, and yesterday my wife decided to take a 60 mile trip with no oil. well she made it about 48. needless to say the freshly rebuild has gone kaplonk! sounds like a busted lifter and a thrown rod. regardless the engine is done for.:sadsmilie

so i was in the process of trying to sale the car (obviously running) but it looks like it has become a parts car. If you want the whole thing bring a dolly and you can have it for $600. search my for sale post and you can see pix of it.

but if i am willing to part out.

so pretty much i got everything in there for sale except for::

middle console
and side trims
and no intake plastic tubing


the dash is good just NO vent plastics

oh and the exhaust manifold has been replaced with a pace-setter header

the car has everything else. just throw me an offer and we will go from there (plus shipping in which i get discounts). please be reasonable i just put over a grand in the rebuild and am really trying to get some of that back.

any other questions just pm me or call me at 281-990-4065
 

·
Registered
Joined
·
2,121 Posts
48 miles with no oil? :door:
 

·
Registered
Joined
·
837 Posts
Discussion Starter · #3 ·
yeah this makes number 2 that has went to sh*t on me for the same reason..
 

·
Registered
Joined
·
837 Posts
Discussion Starter · #5 ·
nah she is a good one..... just now learning the ends and outs...
 

·
Registered
Joined
·
464 Posts
does that year model have a sun roof?? if so, i want the cables out of it. if the little plastic connector hasn't broke. i tryed fixing mine with some j-b weld, held for bout 10 openings and broke again.. i tryed that after i found out it was going to cost 500 bucks to fix it from the Toyota place ha ha..yea right!!!! someone needs to make some aluminum connectors for that thing. but anywho pm me plz if you have them.
THANKS,
Cody
 

·
Registered
Joined
·
1,077 Posts
Why would it have no oil after a fresh rebuild?

If it started out with oil "full", where did the oil go?
 

·
Registered
Joined
·
402 Posts
Why would it have no oil after a fresh rebuild?

If it started out with oil "full", where did the oil go?
i have a feeling he was getting to putting the oil in and didnt get a chance...

thats why I and ONLY I drive my car lol!
sorry to hear the bad news dude...
 

·
Registered
Joined
·
837 Posts
Discussion Starter · #14 ·
dragon84.......... the interior is blue and the wheels are stock
 

·
Registered
Joined
·
837 Posts
Discussion Starter · #15 ·
ghoul........ no the dash is blue and as for the vents are you talking about the omes located directly below the windshield or the ones on the left side of the cluster guage and the right side of the dash right next to the pass. window? i have the ones below the windshield and they are good but not the other ones.
 

·
Registered
Joined
·
837 Posts
Discussion Starter · #16 ·
and no i knew i had an oil leak i saw it but was not sure were it was coming from but before i was able to locate the culprit it was to late....
 

·
Registered
Joined
·
199 Posts
keep your wife, good cars are much easier to replace and much less costly!
Woah woah woah, wait a second. Its cheaper to replace a wife. All you need is a shovel, some biodegradable lawn and leaf bags, and a big bag of lye. Problem solved!
 

·
Registered
Joined
·
837 Posts
Discussion Starter · #20 ·
come on lets keep to the thread........ my wife stays blowin fresh rebuilds or not. lol
 
1 - 20 of 35 Posts
Top