Toyota Celica Supra Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
310 Posts
Discussion Starter #1
I have had this problem as of recent. The problem is that when I rev the engine over 4500rpms my battery warning light turns on and also my e-break warning light. I noticed that near 4800rpms the battey warning light dims out. The battery gage is a little over 12v and does not drop. Another problem that I have noticed is that when I push on the breaks the my headlights somewhat flicker like they wanna turn off 4 a milli-second also there is no significant drop on batt gage. Any suggestions. I was thinking it might be the alternator. I got to go 4 now.
 

·
Registered
Joined
·
57 Posts
Do you have a multimeter? If you do, then check the battery voltage with the engine running, it should be around 14 volts (+ or - 0.3 volts). If not, then you have a bad alternator. The other thing to check is to make sure the alternator belt is tight.
 

·
Registered
Joined
·
209 Posts
Pokeyguy is correct,

I would use a multimeter to check your voltage as you rev your engine. It sounds like your voltage regulator is either bad or going bad. If you rev the engine and the voltage goes above 15 volts, then your regulator is not working properly. The regulator is in the alternator on the MkII, so replacing the alternator is the easiest way to fix it.
 

·
Registered
Joined
·
310 Posts
Discussion Starter #4
yeah i swaped the alter from my blue mk2 into my SDR mk2 and it seems to of fixed the problem i also installed new brushes sp. at the moment i will intall new belts for alter and powersteering and i will intall a new water pump, ive been having heaten problems but thats a different story. I know it sounds like my car is craping out from all my post but not really. I also like working on my car and its also an almost 20year old car.
 
1 - 4 of 4 Posts
Top