Toyota Celica Supra Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
382 Posts
Discussion Starter #1
Any help/thoughts would be appreciated. My supra has just developed a problem, where the brakes will pulse when applied. It feels like the brakes are skipping. The Vibration is quite noticable, and irritating. :x I just replaced a brake caliper that I though was the problem and flushed the system and put in new brake fluid.

The only other thing I can think of is a warped rotor.

Any thoughts?

Thanks,
Mitch
 

·
Registered
Joined
·
1,457 Posts
I agree. Try to sping the hub (preferrably w/o wheel) and see if it spins smoothly all the way around. if it catches on spots then yes.... warperooni.

Christian
 

·
Registered
Joined
·
310 Posts
Warped Rotor is what it sounds like. Ive seen this problem before with my dads car in his case it was a new rear defective drum. I know that the noise and vibration is intollerable.
 

·
Registered
Joined
·
675 Posts
warperooni is right I do believe.
Mine had the same problem and the answer to it not doing it again.......
get that torque wrench out on them there lugnuts!!!
replaced rotors 2 years ago, use t-wrench everytime and no prob.
 

·
Registered
Joined
·
43 Posts
Same thing is happening to my car right now. I just had a shop rebuild the calipers (fresh from Toyota), put new rotors front and rear (brembo OEM replacement), new pads (Toyota), and braided brake lines.


The car stops fine, but when I put light pressure....I mean really light pressure on the brake pedal I get this pulsing. Did you find out what it was, I'm going to take it into the shop again and have them look at it? Please advise.

Oh, here's the pisser. When I picked up my car I noticed it only had 3 lug nuts on each wheel. I had them put on the 4th lug nut on each wheel and the guys torqued it down with an air hammer right in front of me. I was going to kill him. I hope it is not a warped rotor because if it is, they're going to pay for it.

-jason
 

·
Registered
Joined
·
791 Posts
Brake pulsation is always a warped rotor (or drum in some cases). If it has happened just after someone doing a brake job or tire rotation, it is quite possible that they did not use a torque wrench to tighten the lug nuts properly, and put them on with an impact wrench. Other common things that can cause this problem would be rust scale or something else stuck between the rotor and the rim when bolted in. This foreign matter will cause the rotor to sit a little crooked and cause that sensation.
Finally, if you have brand new rotors and have not "seasoned" them properly, you can warp them in a matter of minutes-believe me, I know!
You shouldn't drive your vehicle with new rotors for any extended periods at a high rate of speed. The rotors are very rough and the pads are trying to "seat" themselves into that rotor. While it is doing this (usually the first 200 miles), the heat buildup on a rotor will be extremely high, sometimes enough to glow red from the friction.
You should also avoid running into water on a dry day, the cooling effect of the water can cause warpage instantly. You should also avoid hard stops in that first 200 miles.
I warped a brand new set of power slots on my Durango a few years back by driving it on the highway from the shop that installed them. It was only 20 miles home, but the 70+mph (and the offramp braking too) was enough to heat a spot on them and cause a noticeable "bump" from the brake pedal. Ended up having them turned 2 months later, taking it real easy for 250 miles, and haven't had the pulsation back since.
 
1 - 7 of 7 Posts
Top