Toyota Celica Supra Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
So on an icy night a few months ago, I managed to slide the car sideways into a curb, bending the hell out of the passenger control arm. Not having time/money to fix it, I put the car in its parking spot and left it. The first month or two it was out there, I managed to keep up with at least starting it, letting it warm, and then shutting it down. Well, now I have the cash and time to replace the control arm and what do I find? I can't start the damn thing.

I just tried to have it jump started, but no luck. I hear a loud, rapid clicking and that's it. No sign of the engine turning over. What might have died from lack of use? Starter? Engine seized? Where do I start looking? :(

Thanks for any and all advice...

Tom
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #7 ·
fixed it! every connector turned out to be shiny and even after another go at jumping the car, nothing happened. So I made a sort of tutorial day out of working on the car with my girlfriend and we pulled and replaced the starter. Car turned over immediately, although not without a lot of black and gray smoke... :) oh well, I suppose that means the valve stem seals will need replacing at some point, but otherwise I have a working supra again.

Thanks again folks!
tom
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top