Toyota Celica Supra Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
85 supra. Headgasket went. Replaced it as well as rebuilt the head with a mild port job. Reassemble car. Timing and dist timing dead on. Try to start car and cel is not there like normal when ignition is first keyed on and disappears when car starts...no...its on and flickering with ignition off and key out. No spark from distributor. Plugs wet w fuel. Distributor is at 166.5 ohms so well in spec. Coil in spec too (msd blaster ss coil) yet car ran perfect before. Ground strap to head on and tight with good connect. Relay 1st on left bottom feels hot even though car wont run. Dunno if ignitor is bad or ecu. Cel wont flash or even show up with jumper. Please help.
 

·
Super Moderator
Joined
·
8,315 Posts
I would go thru and check all your connections and then the wire conditions. You unplug a lot of stuff doing that job. You may have just missed something somewhere.
 

·
Premium Member
Joined
·
5,881 Posts
Please ignore .. the CEL.
Go back and look at the coil spark and the injector signal FROM the injectors.
A back up coil/ignitor is REQUIRED.

Bypass /short the yellow plug from the AFM and see/feel for fuel pulses pulses from your fuel pump AND
Ignition and verify spark.
FLASHING CEL is a bit strange, EH?


If the codes are not readable, there is no information.
Please continue with your diagnosis.
 

·
Premium Member
Joined
·
7,850 Posts
Check the EFI fuse under the hood too...
 

·
Registered
Joined
·
223 Posts
Check 7.5 IGN fuse in kick panel, supplies power to #2 EFI main relay on fender by fuse box and powers coil and igniter. You said relay on left are you referring to the one in engine fuse box, that would be EFI relay 1 that powers ecu and other things. That might be why the check engine light is on with key out, relay stuck closed.
 

·
Premium Member
Joined
·
5,881 Posts
Drivers kick panel? WHOA!
 
  • Like
Reactions: AJ
1 - 6 of 6 Posts
Top