Toyota Celica Supra Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I recently had an engine rebuild on my 1984 celica supra, ever since it has started rough, its always only in the morning so the cold start injector has been replaced, still did it, so then had the o2 sensor replaced, after replacing that it still does it but not every morning like before. Wondering what it could be. After it starts it runs just fine.
 

·
Super Moderator
Joined
·
10,395 Posts
Does it idle up like it should? It will run very rough if it can't manage the 1500-2000rpms its supposed to hit. The 84s have the plunger style idle valve which is normally quite problem free, but it is mechanical and can fail. If its working right and trying to idle up but not getting enough fuel to sustain the high idle, it probably is still your cold start injector. Just because you replaced the injector doesn't mean that's not the problem. Test it. You can unbolt it from the TB and hold it hooked up to fuel and the connector but point the injector outside of the engine bay (maybe hold a container under it for fuel dribble). Then start er up cold and see if its actually firing. It should be a nice mist. Prime cause when this happens is the temp switch in the thermostat housing (see FRSM to identify it, I belive its the one closest to the head). That sensor can just stop working, though rare (its easy to test with a continuity test on a multimeter, see FSRM). If you confirm its in good shape and your injector isn't firing, test the wiring between that sensor and the connector for the cold start. I had a mk2 with really high miles and this exact same problem and the connectors were crumbling and the pins corroded. Cleaned all that stuff up and or replaced the connectors, and it started working again.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
Thank you! This should definitely help me figure out the issue! When I crank it its very shaky, rough ,and sometimes takes a second try then idles just fine and drives perfectly. I feel it definitely could still have to do with the cold start since its still only in the morning. Maybe something was contaminated from the rebuild since this started after?
 

·
Super Moderator
Joined
·
10,395 Posts
Warmed up? 800-900rpm works well. I think the spec is a little lower, but that can be hard to hold without stalling sometimes on high mileage cars.

Your symptom sounds most like a cold start injector problem to me.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
Everything was all good with the cold start injector, connectors and pins are all good. I was recommended to try a fuel octane booster
 

·
Registered
Joined
·
4,116 Posts
Warmed up? 800-900rpm works well. I think the spec is a little lower, but that can be hard to hold without stalling sometimes on high mileage cars.

Your symptom sounds most like a cold start injector problem to me.
Agreed. Could be the ecu is not getting a cold engine signal. A new cold start injector does not solve the problem. Possible damage to engine harness during the rebuild
 

·
Registered
Joined
·
15 Posts
Discussion Starter #9
It started up nearly perfect yesterday , its not everytime for some reason . Right after the o2 sensor was replaced it didnt do it for a few days then it started to do it again
 

·
Registered
Joined
·
15 Posts
Discussion Starter #10
But it is still in the mornings when it does do it so cold start still very much makes sense... im going to have a shop check wiring and all
 

·
Super Moderator
Joined
·
10,395 Posts
Sounds like a connection problem, they can change a lot with wiring. Just unplug the connectors on the sensor and the cold start first and inspect the insides of both side carefully. Often its just some corrosion in the connection. Next step is the wires in between the 2, the insulation could could have cracked and the wire started to corrode.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #12
There was a ripped vaccum line on the intake manifold, fixed that . Also replaced the fuel pump . Its starting better than it ever has thankfully!!
 
1 - 12 of 12 Posts
Top