Toyota Celica Supra Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
310 Posts
Discussion Starter #1
I am getting check engine lights in my MK2. About a week ago it came on and I turned the car off and then turned it back on again and it didn't come back on. Then on Sunday it came back on so I turned the car off and then it didn't do it until I started the car this morning it came back on. I don't know what it could be, the car runs fine. I don't know how to get codes on an Mk2 like I could do on my old MK3. Anyhelp would be greatly appreciated.
 

·
Registered
Joined
·
9,445 Posts

·
Premium Member
Joined
·
7,984 Posts
When was the last time you changed your O2 sensor?? Probably the source of the error code.
 

·
Registered
Joined
·
310 Posts
Discussion Starter #4
The 02 sensor was replaced about a month ago. Also there is a connector than is right next to the AFM that is unplugged, could that be it?
 

·
Registered User
Joined
·
3,283 Posts
sd85supra said:
The 02 sensor was replaced about a month ago. Also there is a connector than is right next to the AFM that is unplugged, could that be it?
what are the codes in the ECU?
 

·
Registered User
Joined
·
3,283 Posts
Abomination said:
I get a check engine light if I push my car too hard on the freeway... is this normal?
I had a check engine light come on above 75mph and WOT. checking the codes showed it was an O2 sensor. changed the O2 sensor and all was well.

This seems to be the most common way to tell if it's the O2 sensor (along with the check engine code) High speeds and check engine light lighting up...

Mike
 
1 - 7 of 7 Posts
Top