Toyota Celica Supra Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
my check engine light comes on in 5th gear at about 70, when i push it hard, and when i let off the gas, it "sometimes" turns off, but most of the time remains on. anyone have any idea what it mite be, before i pull the engine codes. just wanted an expert opinion. i just did the plugs and air filter last week.
 

·
Registered
Joined
·
9,445 Posts
98% of the time it's the O2 sensor.

Pull the codes anyway & see if you get a Code 21.
 

·
Registered
Joined
·
216 Posts
Hrmm, I have virtually the same problem. In 5th at about 110km/h (yes canadian) it will sometimes come on. If I leave off the gas a bit it goes off and I can usually speed up and continue even faster without it coming back on. It also happened while I was running it hard through some twisting roads with lots of speed changes.

I'm curious if the O2 Sensor fix worked, or if you tried it.
 

·
Registered
Joined
·
1,855 Posts
yeah that sounds like an O2 sensor, also it could be the car leaning or riching out, mine does the same thing when I keep it at higher rev's or am varying the throttle alot (twisties or track). Have you modded your car at all? Intake or exhaust? If so re-setting your cars computer can help.
 

·
Registered
Joined
·
216 Posts
Just putting holes in the air box.. =) And I reset the computer after I did that. But it was a couple months back so I'll reset it again. Dave's site also mentions adjusting the AFM, mind you that seems to be geared for real mods.

In the end, I'll do both the AFM and new oxygen sensor...
 

·
Registered
Joined
·
1,855 Posts
You check engine light will come on if you are running rich, which your car will do when running at high rev's, in twisties and whatnot, in that case its not a prob with the sensor, it's just that the car is running rich, this is normal.
 
D

·
Guest
Joined
·
0 Posts
I had the same problem with my 87 Cressida, when i jumped on it the lite would come on. I put Tech-Ron addiitive in the gas tank with a full tank. Problem went a way. Never reoccured again.
Dick B.
 

·
Registered
Joined
·
591 Posts
if said this thousands of times. if your riding the car HARD and the light comes on it ISN'T the o2 sensor. anything past 80% throttle the afm and o2 sensor aren't used anymore it goes back into closed loop mode and uses pre-set settings. that is why it runs a little rich when they are ridden hard.

it is probably slight knocking and the ecu is picking it up. the knocking could be from advanced ignition timing, fuel pressur dropping causing the car to go a lil lean, carbon build up in the chambers heats up when you ride it hard causing pre-ignition. carbon build up is really bad in these engines. the crankcase vetilation system these cars use cause excessive carbon buildup and the aluminum heads don't help.
 
1 - 8 of 8 Posts
Top