Toyota Celica Supra Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
86 mkII p type. 150,000 miles Prod date Oct 85. Got a check engine light. ck the service records dated 1999. here is what it said....
Ck.computer for codes.Knock Sensor is Set A Code.
Ck wiring Ok and sensor, All Ok.
Try using better gas.
My neighbor who i bought the car from said he did that, took it for a long ride and it went out ,but then came back. So just ignored it from then on.
Now ive been running the car on ultra 94 and no change for me either. got my buddys Snap on scanner but can't find the diagnostic plug. So i told him to key in 1985 and it says manual check.How do i do that????? The car runs good, i don't hear any knocks but i did'nt use a stethascope either.
Any direction on this and where can i get a Factory Service Manual????
Thanks in Advance.

Intis
 

·
POTATO
Joined
·
17,259 Posts
Have you got a Chiltons or Haynes manual? It should tell you the codes/ and where the check connector plug is. I believe the check connector plug is near the distributor, I believe a 2 prong plug, but good luck hooking up to it, I went to a shop recently to check my ECU for any stored codes and they didn't have the right plug in :?

Tanya
'85 Blackpra P-5
'84 Blupra P-5
 

·
Super Moderator
Joined
·
8,395 Posts
You don't need a scanner for the MkII. You can use either a high tech paper clip or piece of stripped wire to short the connector then run the engine and count the flashes on the light. There is a specific sequence for each check code. You can read the how to here;

http://www.cygnusx1.net/supra/library/TSRM_MKII/fi/FI_022.html
 

·
Registered
Joined
·
245 Posts
i bet it is the o2 sensor. thats what mine did changed it all better





jeremy
84 p-type
86 pt-ype (auto)
86 p-type (5spd)
 

·
Registered
Joined
·
58 Posts
Discussion Starter #5
I have no manual at all...........would like to find a Factory one if i can .
I was never crazy about the Hayes/ chilton jobs.
mmmmm. will ck near the Dist again. Two prong?????? maybe thats why we could'nt find it.....ay yiiiii...yiiiiiii.........hopefully my friend saved some of is old stuff but i think he traded in is old scanner which probably had the older plugs for a new one which we tried using today.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #6
The stupid o2 sensor crossed my mind. same prob in my v6 toy 4x4. that fixed it.

Also my buddy mentioned about the counting the sequence of blinks.

Thanks
 

·
POTATO
Joined
·
17,259 Posts
I'm interested in finding a list of what blinking sequence is what b/c in the manual it only has the sequence for the 22RE, and I jumped out my connector and the check engine light blinks like _ _ _ _ _ _ like blinks repeatedly, no changes, no pauses except like 1/2 second between blinks, and I have no clue if that's normal or not....

Tanya
 

·
Registered
Joined
·
58 Posts
Discussion Starter #9
Ck eng lite/ Knock sensor code 52

Thanks for all the replies........made a quick jumper w/2 spade connectors and a piece of wire........ Yep......5 blinks pause then 2 blinks. then it reapted the sequence over.... thats the only error code that it displays.

I'm going to reset the the codes and see if it comes back...if it does, i'll be back for more help on this topic.

I'm only a member for 10 days and have learned more than i Imagined about a car i've always wanted since i was a kid.

Thanks Again.
 

·
Super Moderator
Joined
·
8,395 Posts
TanyasMk2Blackpra said:
I'm interested in finding a list of what blinking sequence is what b/c in the manual it only has the sequence for the 22RE, and I jumped out my connector and the check engine light blinks like _ _ _ _ _ _ like blinks repeatedly, no changes, no pauses except like 1/2 second between blinks, and I have no clue if that's normal or not....

Tanya
Blinking like that is normal when you have no codes. You can find the codes in the link I posted above, its about 2 more pages ahead.
 

·
POTATO
Joined
·
17,259 Posts
well groovy, no codes, that means I have a bad wire somewhere to find, blah.... t/y Silver ;)

Tanya
 

·
Registered
Joined
·
792 Posts
Not necessarily, Tanya. Do you get a steady flashing light? Or do you not get a light at all? If you don't get a check engine light at all, your tps is most likely out of adjustment. The tps has to be at a certain position (of course, without depressing the gas pedal) for the system to report back an error code. It's one of the sensors that it checks before giving you your "report".
Good luck!
Chris

Oh, and if anyone wants to confirm this, just read your codes, when the light starts flashing, press the gas pedal. The light stops flashing! Ingenious tps test designed by Toyota or quirk? Guess we'll never know...
 

·
POTATO
Joined
·
17,259 Posts
I do get the check engine light steadily blinking when I jump out the connector, never tried depressing the gas pedal though. But when I have my EFI relay plugged in and it goes bad ( long story, now I have the relay hard wired to avoid cutting off ) the check engine light will not come on when the ignition is on. As long as I have the relay hard wired, it works fine, check engine light and all. I hope I'll find a bad wire to repair when I pull the engine in a couple of weeks

Tanya
 

·
POTATO
Joined
·
17,259 Posts
thanks, damn I didn't even know it was working yet! woohooo!

T
 
1 - 16 of 16 Posts
Top