Toyota Celica Supra Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
i have searched for an answer to this problem, but everyone says different things, and i dont know what is right!!!!
I have a problem with my '84, a lot of the time it just clicks when i turn the ignition, nothing else. It happens at various times, the morning, after not running it for a while and once after a long drive... it will always start, but sometimes it takes literally 20-30 clicks.... is it the CSITS, a relay or starter contacts? or is there a bigger problem?

also there is a squeak from the engine every so often, and usually happens at the same distance when driven, but its hard to judge. If i depress the clutch it goes.... not too sure what it could be.
similar thing happens with the digi dash, when the lights are on and im doing 100km/h the dash just goes off... got a new battery but it didnt help.

Any help is greatly appreciated!!! Thanks heaps!!!!!!
 

·
Registered
Joined
·
591 Posts
check transmission oil level for the squeak or your clutch pad. as for the clicking. sounds to me like a selenoid is out(dirty contracts). if your up for it it probably couldn't hurt to rebuild your starter.
 

·
Registered
Joined
·
126 Posts
Dude your starter selenoid is gone. 1st it happens once awhile, then it got worse and worse right. Soon it wont start. That is what happened to my. I 1st thought it was the alternator.
thanks!
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
ok, thanks heaps guys!! what exactly is involved in rebuilding a starter? not too hard for an ameteur is it? or should i have it professionally checked?
 

·
Registered
Joined
·
126 Posts
Get one from the junkyard, it is usually about $25. If you decide to rebuilt one becareful when taking out the seleniod. It falls apart easily and hard to put it back.
thanks!
 

·
Registered
Joined
·
3,433 Posts
i'm not saying its not the solenoid, but check the battery terminals for corrosion and the the connection at the starter, i had a 2000 solara come into work the other day complaining of a no start, it gave all the signs of needing a starter but i serviced the battery and connection at the starter and bam, started right up.......rebuilding a starter is not that bad, the main issue with are supras are they are a bitch to get off....lol
 

·
Registered
Joined
·
73 Posts
supraii said:
Dude your starter selenoid is gone. 1st it happens once awhile, then it got worse and worse right. Soon it wont start. That is what happened to my. I 1st thought it was the alternator.
thanks!
Yep. I replaced the starter, car starts up everytime perfectly now.
 

·
Registered
Joined
·
126 Posts
Hehe
Actually all you need is replace the seleniod, but in my case i couldnt put it back togather once it got losed.
thanks!
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #10 ·
yeah, a few things in the mkii were placed in odd places...
i'm not too mechanically good, so i guess i wont try rebuilding the starter myself, probably go to the wreckers and get one, then the fun begins of trying to switch the two...hehe

thanks for the help!!
 
1 - 10 of 10 Posts
Top