Toyota Celica Supra Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
485 Posts
Discussion Starter · #1 ·
I'm doing the coversion from a 85mph digi dash to a 130mph digi dash(thanks again Leslie!) and I noticed some weird things when I took the cover off to change the millage to my correct milage(which was pretty easy actually, although I have yet to see if it actually worked.) When I had the cover of the dash off i noticed some strange black marks on the actual glass coverings that cover the speedo, gas gauge, and the temp gauge. It almost looks like the sodered wires inside had come loose on burned the glass. I haven't checked the dash in my car, but I'd like to know if anyone else has noticed these marks while working on the Digital dash? I don't want to install it if these are actually burn marks, cause having the dashboard either short out or catch on fire would be BAD! Again, I'm not sure if it's actually a problem or thats just how they were sodered but I just thought I'd check first. Thanks alot, Brian
 

· Registered
Joined
·
485 Posts
Discussion Starter · #4 ·
Nope I mean the digi dash. The 82-83 model was limited to 85 MPH, the 84-86 was 130. I'm trying to switch it to a 130mph dash. Can anybody answer my question? B
 

· Registered
Joined
·
485 Posts
Discussion Starter · #15 ·
Nope Leslie, Haven't put it in yet. I hope to get around to it this sat. I'll let you know though when i do. Speaking of which, how hard is the speedo cable to detach and attach? I think thats the only big problem i'll have. I'm also gonna go by he toyota dealership tomorrow and find out the specific date for that part.B
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top