Toyota Celica Supra Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 ·
hey all....my prob seems to be a little funny

bout a month or 3 ago my digital speedometer stopped reading speed...just went to 0 and stayed there

when i hit the dash wether the car was moving or not it would sometimes go up to 1-3km/h then back to 0....then i hit it a good few times and whatnot and it started working again

well today on my way to work i was cruisin at about 4000rpm in 5th, and it went to 0km/h....which i figured to be damn near impossible :p

so....any ideas what it might be? i was thinking speedo cable at first but why would it start working again after i hit it the first time....although this time i've been the fuck outta my dash to no avail

my other idea is maybe some kind of ground connection....but i've got no idea if i aground (or any other wiring for that matter) could cause this sort of problem

thanks all
 

·
Registered
Joined
·
160 Posts
almost certiantly sounds electrical to me... You should get back there (or have someone else if youre not sure what youre doing, it's hard) and see if all the ends meet and what not. cuz if you bump it and it works... sounds like it's making two wires that aren't connecting.. connect.
 

·
Registered
Joined
·
1,089 Posts
But Officer ... I was hardly moving!!!

What exactly do you mean by"Step out of the car please???"

Those are nice hand cuffs you've got there ... Oh shit.
 

·
Registered
Joined
·
160 Posts
Reminds me of the time I got pulled over for not having a front plate...

"You have no front plate on your car"
"You know what officer, youre absolutely right, good call"
"Have you been warned about this before"
"Yes, and until I can be cited for it I'm not putting one on"
"The state of Utah gives 2 plates for blah blah blah blah blah"
"Okay, but theres no ticket for it right?"
"No there isn't"

Yeah, one of the few times you can be a smart ass to a cop and not get in trouble.
 

·
Registered
Joined
·
1,089 Posts
I'm not running the front plate on my car either, but in Ontario I think it IS a ticketable offence. I'm not drilling holes in my front bumper untill I absoultly, positively, by order of the court HAVE to.

Sorry, I guess we're not really being any help with the dash problem ... Isn't there another thread about this right now?
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #6 ·
lol....i hate cops....

anyways...back to the problem :p

my only thing about it being electrical is....it still stays on but just reads 0km/h...it doesn't black out

thats what hte other thread is about right now...his totally blacks out, mine stays on but just reads 0

that leads me to believe its maybe the speedo cable, but i don't know how these things work at all....

like....does the speedo cable go somewhere else then the speed is electrically sent to the dash, or does the cable go right into the back of the dash and is interpreted there?
 
G

·
It appears you may have a crack in the PC board. Any vibration changes the reading. Also could be dirty contacts in the plugs.
Dick B. :roll:
 

·
Registered
Joined
·
984 Posts
From what I've seen so far, both the analog and digital have the same "female" speedo cable "attractor". There must be a sensor inside that changes a mech motion to a elec impulse ????
Correct me if I'm wrong please.
DJ
 

·
Registered
Joined
·
4,871 Posts
If I remember correctly, the digital dash has a magnetic pickup inside the housing that's driven by the speedo cable. The magnetic pulses from the pickup are fed through an Analog to Digital converter IC and then through a display driver IC that drives the 3-digit xenon gas tube speedo display. 8)
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #11 ·
so how hard is it to change out the speedo cable?

what does it entail? i'm pretty sure i'm in for a fucking big job....

is this what it sounds like my solution will be?
 

·
Registered
Joined
·
53 Posts
i bet the cable has just dislodged itself.
open up the dash and have a look

i remember it happened to me once when i forgot to plug it back in, the dash lights up but it just reads 0kmh all the time.
 

·
Registered
Joined
·
9,445 Posts
Basically everything below the steering column needs to come out.

Do you have a TSRM??? The exploded diagrams will show you all of the screw locations. If not, look at the online TSRM.
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #16 ·
i crusied through the tsrm and couldn't find a thing on the dash....am i retarded?

lol

any hints on where i might find it? thx
 

·
Registered
Joined
·
9,445 Posts
Yes, you're retarded... (JUST KIDDING) :banme: :imwithst:

Seriously.....

It is there... You have to look in the Body section and just like in my 85 TSRM, it happens to be ALL THE WAY AT THE END of the body section!!!! Not exactly a easy find. :p :p

http://www.cygnusx1.net/supra/library/TSRM_MKII/bo/BO_041.html

Have fun!!!!
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #18 ·
thanks man

looks like i'm gonna try to jack a speedo cable from the local pick ur part...(think it'll fit in my pants :O:O hahaha) and do this job saturday

prolly end up transfering over to sunday...monday...tuesday....arg i hate dashes lol

thanks again tho
 
1 - 18 of 18 Posts
Top