Toyota Celica Supra Forum banner

1 - 11 of 11 Posts

·
Super Moderator
Joined
·
8,393 Posts
Discussion Starter #1
Well I confirmed by worst fears my MkII is damn slow. Ran a slew of 1/4 miles tonight at Sacramento. Best run 15.588 just shy of 89 mph w/ a 2.21 60ft. I had horrible traction problems out of the hole on every run. 2.21 was the best 60ft, and most where in the 2.5+ range. ETs and MPHs were all extremely close. Considering how well the S03s hook up on the street I was a little baffled to say the least. The 2.21 60ft was on a 1k RPM easy launch. Most amusing was a 5k RPM launch (somehow the clutch held) didn't stop spinning the tires into 4th gear (mainly having fun on this one). Most of the races were pretty loopsided. 1st 5 cars or so I ran the slowest was like an 11 flat :shock: . Thank god some Hondas and pickups showed up so I wasn't the slowest. Only decent head to heads were the newer Integra I ran down with the I/H/E mods and a turbo FC that beat me by 3 or 4 car lengths that had at least a loud BOV. At least I can say is that its faster than stock :? . Car would probably run faster without such a fat driver and some car lightening. Guess its time to start building another motor..... I wonder if a 426 Hemi would fit. Damn they sound sweet with a set of header mufflers (what a joke those are)
 

·
Registered
Joined
·
1,613 Posts
15.58 and your complaining? As my car sits right now, I run a 16.21 @ 84 mph. Your 60' times do seem kinda slow tho. Mine were 2.05-ish if I recall correctly...

As Malloy once said... "I fear Dodge Neons"
 

·
Registered
Joined
·
1,108 Posts
that is not bad... yeah that is a bit slow for your 60 but you are not alone... I have the same identical time you have BTW I am running a 6MGE w/ an open air filter, 2.25 cat-back w/ flowmaster, gutted cat, stage III Centerforce clutch, and worn tires... and blown front struts...
 

·
Registered
Joined
·
1,537 Posts
I just went out to the quarter mile and ran my newly acquired 82 Supra.
The car is set up for road racing, not drag racing. It looks like it has Eibach springs all around, Tokico Illumina's on the front set to "5", some type of adjustable shocks on the rear, not sure of the setting. Heavy duty sway bar on the front, stock one on the rear, and a GAB strut tower bar.
Motor is an 82 5M-GE with unknown internal mods. I'm trying to find out what's been done to it. All I can see is nice headers (not sure of the brand, but not Pacesetter) leading to a 2.5 inch pipe that exits just behind the passenger door. Stock intake piping with an open element air filter. No cold air intake (yet!). Twin electric fans. Potentiometer added to the temp sensor line leading to the ECU to richen mixture. If I richen it right up, I can make it run so rich it stumbles at idle and bogs when floored on the highway. For drag runs, I experimented and found my best results by running fully leaned out until about the middle of second gear, then richening it up a bit.
The car has been gutted, with about 400 lbs removed. Full roll cage has been added, so that probably adds back 150 to 200 lbs.
I filled up with gas before going (since the car has no gas gauge), and estimate the total weight with driver to be about 2980 lbs when I ran.
My times were a bit inconsistent due to bad traction (gotta take some slicks next time I go).
My best times were 15.4's at about 89.4 MPH.
My 60 ft times were 2.18 to 2.23 seconds on most runs. I had one 2.8 where I spun the tires all the way through first and second gear and finally got traction part way through third. I'm sure the announcer had some smart-ass comment for me on that run!
From those numbers, I estimate the car's power to be about 153 RWHP or 180 HP at the crank. Not bad for an 82 that started life with 145 HP at the crank!

My friend Rob with his German spec Mk2 put me in my place, beating me almost every run by between 0.1 and 0.3 sec. :oops: Hmmm... More mods needed... Does it ever end? :twisted:
 

·
Registered
Joined
·
793 Posts
I havent run mine yet, but maybe someone with mk2 knowledge could estimate mine so Im not too disappointed. I have an 82 with 5m, intake, 2.5" catback, flowtech high-flow muffler, a new stock clutch, and bfgoodrich radial TA street tires. My guess is mid-low 16's?
 

·
Registered
Joined
·
1,537 Posts
Mk2Racer,

Stock 1982's were supposed to run 17.0 when brand new. With your mods, you should be in the mid to low 16's, as you guessed.

Stock 83's were supposed to run 16.8 when new. My 83 with similar mods to yours plus timing advanced to 14 deg, cool air intake and 100 lbs removed ran 16.1 last year.
 

·
Registered
Joined
·
109 Posts
wow
i feel really slow
so far i have ran my car at two nghts at the strip
the best on my first night was 17.7 and that was when i thought to redline in everygear. this past friday night i ran my car and i did horrible i shifted at 5500 or so in first and second and finished in third at about 5700 or 5800 my best 60 time then was 2.5 and i had good traction only chirped in 1and2. it was real embarassing blowing blue smoke while pulling up to the water box too though i did get some good burnouts. after i was parked letting the car idle for a little while some guy came up to me and asked me what my best time was i told him my best was a 17.7 and for that night it was a 18.1 he sounded surprised he said "come on really what was your time" i tould him i was serious then proceeded to tell him that i have 180k miles on it blown valve seals and a 17 year old stock motor he then said "then why do you push it so hard" i kinda smurked and then told him i have a new motor (6m) sitting at home waiting for it to get put in then he left. i konw my times are terrible i just wanna know how much the 6m is going to improve when i put it in by the way the only mods i have done to my car is an open filter from autozone very cheap well....thats about how bad i am so i thought i might make you guys feel better by telling you how badly i did.

have fun
 

·
Registered
Joined
·
1,108 Posts
well I haven't really raced my old motor on the track and cannot compare to the swap of the 6MGE... well I put on a 6MGE, open filter, 2.25 cat back no cat, flowmaster muffler, 5 clicks AFM mod, Centerforce Stage III clutch.

and my first run (first time) I ran a 16.1 with bad traction... 3000 rpm launch... the tail swerved right and spinning tires on first and second, chirped third... well then 2nd run lunched it at 2000 rpm and made a 15.8 pass... then I was then adjusting timing to 12º - 15º... and made my 3rd run and made a 15.7 pass... then I was still spinning bad on 1st gear... then adjusted launched rpm to 1500 rpm on my 4th run and made a 15.61 pass and for the rest of the day I was making consistent 15.6 pass

Jay
 

·
Registered
Joined
·
1,890 Posts
I gtecked at a 14.2 in the 1/4... Here you launch and your not as excited. On the strip, Only a 15.3 .... excitement got the best of me.. plus a little misty rain doesn't help much either..
Try again this year be4 I do the 7m swap.
Later
 

·
Registered
Joined
·
351 Posts
my truck runs a [email protected] mph......... :shock: haven't gotten my car out on the track yet. hopefully this summer. i'm hoping for low 16s, but we shall see. I need a new exhaust and a manual tranny.
 
1 - 11 of 11 Posts
Top