Toyota Celica Supra Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
126 Posts
Discussion Starter #1
how come my car takes about 10 cranks or about 20 sec. to get to start. Once in a long long time it starts right up. 1st it had problem with the starter seleniod and i changed. That is (i think) when start to do that. At 1st i though it was the battery and i changed the battery and still do the same thing. How or where can i check to make sure I have good grounding that is dealing with starting the car?
thanks!
 

·
Registered
Joined
·
19 Posts
I had the same problem, I cleaned the connector of the start injector time switch and I seen that connectors "STA" and "STJ" stays releases and did not engage correctly, I have also changed the Star injector time switch and now it starts very well.
Look at here:
http://www.cygnusx1.net/supra/library/TSRM_MKII/fi/FI_071.html
(Excuse me for my English is not really good)
 

·
Registered
Joined
·
53 Posts
mayb ur csi is rooted,
u shud check if it actually squirts any fuel..,
 

·
Registered
Joined
·
73 Posts
You might need a new starter, mine did the same thing, then the starter died so I changed out the starter, now it starts up fine every time.
 

·
Registered
Joined
·
126 Posts
Discussion Starter #6
thank you guys, I will check them.
As for the starter I just replaced and the part was from cressida. I dont know it would make any different. When I took it out I notice the seleniod from my supra is larger than the cressida. I just installed a pressure meter this last night. This morning I found out that the pressure did not hold. I went to zero. This same meter is from my brown supra and it holds on the brown supra event after months of sitting. I wonder what could have cause the leak. My guess is the fuel pump. Any idea?
Hopefully not the injectors or the fuel pressure regulator. Visually I did not see any fuel leak or smell any fuel. Dam it I droped the fuel tank before and it is not easy to do it by yourself.
thanks!
 
1 - 6 of 6 Posts
Top