Toyota Celica Supra Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
Hi,
I was driving a few days ago, a local trip, and my temperature guage rose pretty quicky and pgeed in the red. I kept going for another mile or 2, and then parked for a couple of hours. Driving home, had the same situation. No coolant leaking or blowing, but now I'm afraid to drive it again until I get this checked out.
Before I bring her to my mechanic, is there anything I can check out myself to fix the problem?
Thanks,
Keith
 

·
Registered
Joined
·
104 Posts
Overheating

If were you i'd flush out my radiator and put new coolent & H20, 50/50.
Also go and purchase a new thermostat, and dont forget to replace gasket. Also check around to make sure your hoses aren't leaking or cracked. They tend to get hard and brittle as time goes on. If problem still occurs it may be something in your motor. You'll probably want to change your gaskets, which will probably lead you to overhaul your whole motor, it's well worth the money and your motor should run like new, just make smart decisions when looking around.
-melvin
 

·
Registered
Joined
·
793 Posts
Replace rad cap, thermostat (and gasket), flush and refill system, check the fan and clutch that they actually work. When you flush and fill, make sure to "burp" the system, or you will experience problems. If none of those things work, check to see if the guage and temp. sending unit work properly. If they do, replace the radiator as suggested. Also, check to see if your heater core is leaking and there are some hoses that are hard to see, I had one underneath the thermostat housing crack and leak down the hose and drip no where near where it was actually leaking from, PITA to find. Good luck!
 
1 - 5 of 5 Posts
Top