Toyota Celica Supra Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
I know my car isn't the best an it doesn't look the greatest, but when I got the poor thing it was in pretty bad shape. I've replaced the belts, starter, and timing belt (THANK GOD for non-interference engines!!!). It's still got the original 5mgte in it. It needs a new transmission soon (manual). I have a pretty bad exhaust leak on the manifold. It's leaking oil kinda bad but I'm not quite sure from where. I replaced the original wheels with almost brand new ones that i got off matt (lime green supra....can't remember his username on the forum....sorry!). I've been fixing things as they go wrong or need replaced. There will always be the little things here and there wrong with it beacuse it seems like no matter what I fix, it insists on breaking something else again. I've done what I can to fix it up and I think I've done pretty good so far. I can't really do body work yet because of money issues, plus the other stuff listed above are in more need of attention than the body work. But anyway, I just thought I would give you some background before I posted the pics, so here they are:

http://www.celicatech.com/forums/showthread.php?p=30057446#post30057446
 

·
Registered
Joined
·
2,348 Posts
Having gone through a leaky manifold, you can get a used one cheap and they make a huge difference in how the car runs. Otherwise the O2 sensor is trowing off bad signals and generally making the car just not feel quite right when running. Plus, you may be getting exhaust-y smell in the cabin.

Can't see the photos without a membership in the forum you posted in. Photobucket would be a good place to post them up.

Good luck!
 

·
Registered
Joined
·
7,111 Posts
thats a nice SDR 85 MKii supra. So you mean you still have the original 5MGE engine, and not the 5MGTE ;)
 

·
Registered
Joined
·
2,348 Posts
http:// [url]www.celicatech.com/[/url] forums[/QUOTE]

Nice try, Danny, but no cigar. If you ain't a member of celicatech, the image won't show up.
 

·
Registered
Joined
·
2,348 Posts
i did that. they work on my end. eh, i feel kinda lazy and i dont want to save them and re host them.
This is what you get if you aren't a member of that forum



I know, I could have joined in the time I spent responding to these posts, but I too feel kinda lazy.
 

·
Registered
Joined
·
637 Posts
this is what you get if you aren't a member of that forum



i know, i could have joined in the time i spent responding to these posts, but i too feel kinda lazy.
.........x2
 

·
Registered
Joined
·
20 Posts
Discussion Starter #12
sorry bout the pictures guys...this was my first picture post an I have no idea how to post them correctly....I tried reading the sticky for it but it just confused me...I'm the type of person that when it comes to directions, you gotta spell it out for me...
 

·
I like Boost
Joined
·
3,725 Posts
1) www.photobucket.com

2) right hand side "Join Now Its Free"

3) Go to your photobucket home

4) Upload images

5) Put your cursor over the image you want and a little window will appear.

6) copy the last link with the YOUR-PHOTO[IMG]


only because I'm curious what you've got
 
1 - 14 of 14 Posts
Top