Toyota Celica Supra Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 ·
so i'm driving home from work, and mash the gas in 2nd and it stutters around 5k rpm then at about 5.7k it has a HUGGGGEEEEE bang and i think i saw some somke behind me and thought OH FUCK...

then driving the rest of the way, it drove pretty alright, a few stutters then half way home it started driving like a fuckin champ....like....awesome

any idea what happened and if it was bad? if u know what happened...do you posssibly know why?

the only thing i can think of is maybe a mis-fire a few times in one cylinder then all the excess fuel ignited at once? :S hmmmm
 

·
Registered
Joined
·
2,244 Posts
i bet when u saw that smoke u thot ur engine came out ur muffler haha. hmm so it drove BETTER after all that?. maybe it was burning excess carbon in the system? getting all the dirt and grime out? have u done anything to it lately? oil change? new gas? higher octane? fuel stabilizer or fuel cleaner additives? maybe ur exhaust was clogged with sumthing (potatoe works well mwahhahaa) and it blew out at a high rpm heh
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #3 ·
well it was doing it again later tonite...but worse some times

maybe it was my imagination that it was running better....:S

but anwyays....later on sometimes it would run awesome and rev right to 6400 and others it would stutter HARD around 5500 or so, and if i kept my foot on the gas it would go KABANG again but if i let off it would shut up....pretty fucking weird :(

i have no idea what this is...any ideas ppl? plz help :(
 

·
Registered
Joined
·
591 Posts
sounds like a fuel system intermitent problem might be your fpr going hatywire orr injectors bouncing(staying open completely at wot) that black smoke and bang could be a backfire.
 

·
Registered
Joined
·
7,111 Posts
I have one question, why do you keep beating on that engine if you know something is wrong with it? :scratch: :confused: Beating on it is not gonna fix that problem :suicide: just something to think about :wink:
 

·
Registered
Joined
·
1,374 Posts
DKJones96 said:
sounds like a fuel system intermitent problem might be your fpr going hatywire orr injectors bouncing(staying open completely at wot) that black smoke and bang could be a backfire.
I'm with DK. Your explination definitely sounds like a backfire taking into account the hesitation before hand, bang, then the smoke. If you don't want to investigate the regulator and/or pull the injectors, one quick attempt at a remedy would be to fill the tank with premium and a high quality fuel system cleaner/additive. This MIGHT unplug a sticky injector...if that's the cause.

Fuel for the soul.
Scott
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #8 ·
ok...well here's the deal

i changed my oil from mobil 1 15w50 to castrol gtx 10w30 (for winter, and cuz i didn't quite have the money for synthetic this round) and ran a kleenflo engine flush beforehand cuz i was a little over for the change

then i put in the oil and put in a stop leak (sweaty front main) and changed the ac belt, this is all that was done to the car

i think the oil was a *little* bit over full but not like a liter or anythig, maybe a point or two tops...

could it have anything to do with any of this? or u thin kits just coincidence that i did this then i had problems? could the timing belt have jumped a tooth or would that totally fuck my timing up? probably eh...fuck

it runs quite nice until it stutters and poops but it isn't nearly all the time, just once in a while and afaik only at WOT (i have serious issues with holding my engine at 6k rpm if there's no load on it and without it being WOT, so i don't know for sure if it happens not at wot but i think it doesn't cuz i tried a little...but i hate the feeling)
 

·
Registered
Joined
·
591 Posts
you may be right about the timing you shouldn't have to be anywhere near wot to free revv it to 6k maybe 10-15% throttle

does it pull hard at all? even stock these cars should pull your head back when punching it at 30 in first.
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #10 ·
no no no, i think u misunderstood me

it pulls like a fuckin banshee lol

i just don't ENJOY free revving it to 6 grand, i just hate the sound of a motor being held near redline lol, i guess it probably isn't bad for it at all, probably easier on it than with a load but it just irks me lol

i somehow doubt it actually is the timing belt, i just threw it out there as a bone for someone if maybe they had an idea, but the way it pulls is pretty much nuts when it doesn't backfire

like, if i punch it in 1st at 2k rpm my tires will spin totally out if theres ANY moisture, or even if the tires/road are cold, and if its all dry they'll spin if i punch it from a steady 3.5-4k or so....so there's no lack of power, there's just this annoying problem
 

·
Registered
Joined
·
591 Posts
yeah i did misunderstand you i thought you said that it would hardly do 6k at wot and frerevving isn't hard on an engine at all. i'm never afraid of frerevving a lil past the redline, it's under load that high rpms can hurt.
 

·
Registered
Joined
·
984 Posts
PLUG WIRE !!! 1/6 at least in my opinion !!!
Sounds and feels just like fuel loss.
Has happened twice to me. Cause: Heat soak.
Dont buy cheap wires.
DJ
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #13 ·
well i AM using cheap napa plug wires, and my engine does get run relatively hard and does warm up quite a bit....think it could be that the wires are fucked? i dunno...just seems like that wouldn't make sense but i'm open to suggestions
 

·
Registered
Joined
·
2,244 Posts
just a thot, but is the throttle getting stuck? have u cleaned ur throttle body plate? my car stutters a tad from 1.5 to 2.5k RPM in 3rd in fact it does a double jolt, i.e it stutters at like 1.8k once like a little jolt then again at 2.5k then smoothes out, but i have a backfire at idle thats from my throttle body being dirty and me being too lazy to disconnect the intake assembly to spray it with sum carb cleaner and wipe it. or make sure a vacuum hose sumwhere isnt disconnected or cracked which makes ur car go insane for sumreason
 

·
Registered
Joined
·
195 Posts
Well, one of the first I'd do is check each of the spark plugs. If you find any unusual deposists on them , then that might give you yet another clue as to what might be causing this.

- Mike
 

·
Registered
Joined
·
3,051 Posts
my car had a bad wire and it would work sometimes but not others. when it worked the car tookoff when it diddn't it was really hesitant and stuttery.
ngk's cost little more than stock wires were i got them, like 6 bucks can. or so, well worth the extra, same with ngk plugs.
 
1 - 16 of 16 Posts
Top