Toyota Celica Supra Forum banner
1 - 20 of 45 Posts

·
Registered
Joined
·
659 Posts
Discussion Starter · #22 ·
If I ever manage to find a replacement seal then I’ll cut my hatch open and happily take pictures… Until then it’s only the silicon keeping the rain out :) The angle that it’s at suggest to me that the cables are also gone but that’s probably a guess until I dare to cut the thing open
ok let me see what i can do
 

·
Registered
Joined
·
659 Posts
Discussion Starter · #25 ·
Would you be willing to ship some parts to Denmark ?
In this case, fog lights(the ones integrated in the bumper), edge covers for the windshield (Not exactly sure about the name), rear exhaust hanger bracket, and the indicator/wiper ASSY for the steering column?
what year is your Supra? i cant help with the fogs but other stuff possible, does you indicator/wiper assembly for the steering column have cruise control?
 

·
Registered
Joined
·
659 Posts
Discussion Starter · #29 ·
It's just old.
When i got the car 3 months ago, the hazard button only flashed with the left side, that was fixed by using some contact cleaner and turning it on and off many times.
The problem i still have is when i indicate right, the hazard light in the dash(Digital dash) is also blinking, otherwise it works fine.
ok that is why i was asking, my 84 didnt work until cleaned but maybe yours is worn, ill check like i said, ill send you a PM
 
1 - 20 of 45 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top