Toyota Celica Supra Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
I've had this issue for about a year now, and it's just gotten worse.
Headlights work fine, unless I hit the brights. Then the brights work, but the regular lights won't. Totally dark. Turn the lights on & off, still nothing. I end up driving home then with the brights on, generally irritating everyone else on the road.
I've tried spraying electrical contact cleaner on the switch at the steering column, but nothing.
Of course, I try NOT to hit the brights, but it's a sensitive switch, and I'm a bit clumsy.
Any ideas?
Thanks guys,
Keith
 

·
Registered
Joined
·
4,871 Posts
When you say that the regular lights don't work with the brights On, what lights are you referring to??

Dave A.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #3
once I've hit my brights, and then go back to the regular headlights, the regular headlights are dark. at that point only the brights work, the reg lights won't light up at all.
 

·
Registered
Joined
·
655 Posts
re: headlights

Hi Keith,

I've had the same problem with my 85 Supra. Sometimes my headlights would even go out if I hit a really hard bump in the road. I either had to switch to my brights for light, or if the situation wasn't to dangerous I would play with the column mounting headligh stalk, trying to get the low beams back on. I have had my car in storage for awhile now so I haven't tried looking for the problem since, but I have a suspicion that it probably has to do with the column stalk getting dirty or loose inside. I am also interested in what other people have to suggest on the issue.

Sonny
 

·
Registered
Joined
·
7,111 Posts
I had this problem too last year on my 85. My lights would go out and only my high beams would work. the problem was that the light switch was broken in side. I went to the local Junkyard and found one in good condition, I swapped them and I havent had a problem with it yet. :wink:

HTH, Laterz zankone
 
1 - 6 of 6 Posts
Top