Toyota Celica Supra Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2,741 Posts
Discussion Starter #1
im having an issue with one of the head units in my cars. honestly, im stumped as to how to go about fixing it. the radio functions perfectly fine. i can change stations, cd's work fine, even the ipod. all the buttons light up, except for the screen. the screen doesnt work at all. no display, so i have no clue what song or station im listening to, nor can i make any adjustments to the radio. i tried cleaning the contacts on the back of the faceplate and radio, i made sure none of them were bent, and still nothing. its a pioneer deh-4900mp. its well out of its warranty period so thats out. its a great radio, well, prior to this happening it was great. completely random too. one day it worked, and the next, nothing. if anyone on here is good with electronics and wants to shed some light here, id appreciate it. id like to at least attempt to fix it. i looked on ebay to see if i could find a used face plate and theres nothing. id hate to just throw out a good radio for a stupid little issue.
 

·
Premium Member
Joined
·
7,940 Posts
Danny, sounds like your best bet is to find a new faceplate, I have a DEH-P2000 and the buttons just were worn out...

Founds this while searching...on http://www.caraudiocentral.net/forums
Sounds like the faceplate is losing communication with the HU. I dont know how often your faceplate is removed but you can try this.

Remove the faceplate and check the contact area where the faceplate mates with HU. I believe the faceplate will have gold plated pieces that make contact with pins coming off of the HU. Check to make sure that there is no corrosion at any of the contact points and that none of the pins are bent. Also sometime the gold plating can start to flake off so make sure they all are still covered.

probably a bad connection between the face and H/U... Quite often dirt gets trapped in the the prongs... best thing to do is clean it with rubbing alcohol and a Qtip... be careful with the Qtip though so you don't get the fibers stuck in the prongs or it's just a new problem.
__________________
 

·
Registered
Joined
·
348 Posts
I've had quite a few Pioneer head units. I don't recall what kind of display yours has (LCD, dot matrix, analog bulb), but it sounds like the faceplate lighting circuit is not communicating. It could be a simple bulb replacement, or a broken circuit on the board. If it's no longer covered by warranty, break out your mini-screwdrivers, a soldering iron, and a magnifying glass and take a look for yourself. HTH :thumbsup:
 

·
Registered
Joined
·
2,741 Posts
Discussion Starter #4
im pretty sure its an lcd display. ive already tried cleaning the gold plated contacts but that didnt do any thing. none of the prongs looks bent. like i said, the face plate buttons light up, and everything works, except for the display. i wouldnt mind trying to solder whats broken myself, i just have no idea what to look for.
 

·
Registered
Joined
·
348 Posts
I'd try taking it apart and, with a magnifying glass, follow the circuits going to the screen. Another thought is to use an ohmmeter at the beginning and end of the contacts.

I had a truck that got stolen that had a Pioneer cd player in it. They stole the faceplate and the speakers. The rest of the HU was fine. I contacted Pioneer directly, told them what had happened, and they offered me a new replacement faceplate. This was about 6 years ago and the replacement cost me around $60 iirc.
 

·
Registered
Joined
·
2,741 Posts
Discussion Starter #6
ill have to take it apart like you said i guess. its really not worth me buying another face unless were talking like $20 bucks or so. i got the radio for $75 shipped over a year ago.
 

·
Registered
Joined
·
348 Posts
Pioneer just might have a surplus that they want to get rid of. It might be worth making the call.

At least you got a sweet deal in the first place. :thumbsup:
 

·
Registered
Joined
·
2,741 Posts
Discussion Starter #8
well, i just went outside to grab the faceplate. i turned the car on to see if anything happened and the screen lit up and worked for all of 30 seconds. it was alot dimmer then normal, and it just faded out until i couldnt read anything anymore. i took the back of the faceplate off, but im not exactly sure what i should be looking for.
 

·
Registered
Joined
·
788 Posts
i found a company that will fix the FP or whole unit for a good price. i had them fix my FP as well when i had this issue and they did a good job. i'll see if i can dig up the info again. it's been a while.
 

·
Registered
Joined
·
348 Posts
At this point, I believe that it's beyond home repair. Check out what SolidStateS15 can find for you. You could try to find someone local who does this kind of stuff. Who knows, you might end up having to get a whole new unit. Sorry I couldn't help any more.

I wish you luck!
 

·
Registered
Joined
·
2,741 Posts
Discussion Starter #11
yea, i kinda figured that. i already have another radio for the car since im doing a custom double din radio install in my truck, i was going to put the alipine from my truck in the supra because it has better sound adjustability and more power output. im kinda bummed though, it was a good radio, that was simple yet functional, and the ipod was super easy to operate through the radio. not to mention i already had someone that wanted to buy it from me.
 
1 - 11 of 11 Posts
Top