Toyota Celica Supra Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
686 Posts
Discussion Starter #1
Someone out there has had to of had the same heating issues that I’m having. Both my MK1’s are having issues. My burgundy one will blow straight heat all the time. You can’t adjust it at all. Just the blower speed. The heat in my other one is working at the moment but on my way into work this morning I was hearing a random clicking sound coming from behind the dash as I set the temperature. It would continue for a few second then stop then click randomly again. Any ideas where to start with these? I really need to fix the full time heat issue in the other car. It makes it hard to drive.
 

·
Registered
Joined
·
212 Posts
either your heater control valve (under the hood) is stuck wide open, easiest to fix if you can FIND a replacement! (about a 10 minute job IF you drink a beer while doing it!)
AND/OR the flap that moderates the cold air mix is not moving, might be a bad vacuum line or it might be frozen closed (THIS is more than likely the problem)..... the latter is a pain to even get to, but my when my mechanic replaced my blower fan, he lubed all the moving parts in the heater box.... other than those things, thats about all I know about the Supras a/c system, hope that helps

and the second one clicking, is not a big deal, just the "automatic" temp making its adjustments! wouldn't worry about it unless it stops working!
 

·
Registered
Joined
·
686 Posts
Discussion Starter #3
Hey thanks for the input on this. She’s in the garage just hanging out and I thought I may take a swing at fixing the heat. Now it seems her starting issue has reshowed it’s self so I’m thinking its time to drop the tank. YUCK!
 
1 - 3 of 3 Posts
Top