Toyota Celica Supra Forum banner

1 - 20 of 27 Posts

Registered
Joined
1,206 Posts
Discussion Starter #1
I just wanted to say hi to everyone 馃槉. I finally got an mk2 and decided to come back to the forums. I'm sure a few of you remember me from years ago. After reading some of the posts i wrote in my 20s, all I can do is is say sorry if I was a pain in the ass. Lol. Anyway, I dove head first into a boosted 85 6mgte with full megasquirt. I look forward to meeting and reconnecting with the few people I see lurking around here.
-Larry
 
  • Like
Reactions: Beernuts and Tanya

Registered
Joined
1,206 Posts
Discussion Starter #3
Thanks Dean!
 

Registered
Joined
1,206 Posts
Discussion Starter #5

Registered
Joined
1,206 Posts
Discussion Starter #7
It's good to be back, but I have forgotten so much. I'm reading some of my old posts and im thinking, did I actually know what I was talking about? Lol
 

POTATO
Joined
17,252 Posts
Re-reading old posts is so damn awkward. I can't believe I wasn't banned/deleted/cancelled after my 5000th post 馃槀
 
  • Like
Reactions: AJ

Registered
Joined
1,206 Posts
Discussion Starter #9
Re-reading old posts is so damn awkward. I can't believe I wasn't banned/deleted/cancelled after my 5000th post 馃槀
Right!!!???? I was reading one where I just dressed the fuck down, some poor guy trying to sell an engine. It was sooo cringy.
 

POTATO
Joined
17,252 Posts
Oh man we were on a different level back then. Now we get to be dicks on Facebook and it's somehow much funnier 馃槀
 

Registered
Joined
1,206 Posts
Discussion Starter #11
True, I was pondering the downturn in posting on this forum since I was on it. I realized, we used this and other forums along with messenger groups as our Facebook. If not that, then a least a considerable share of my attention was given to this forum for things i am now doing on Facebook. Like shitposting
 
  • Like
Reactions: Tanya

Registered
Joined
1,206 Posts
Discussion Starter #13

Super Moderator
Joined
10,544 Posts
Larry's back!

Ha ha Billy, Lar wasn't that bad lol

Good to have you back man, the board is still going, need to drag a few more peeps away from FB is all. Maybe I'll see you at a meet in WA next year, 2020 is a wash out sadly.
 

Registered
Joined
1,206 Posts
Discussion Starter #16
Larry's back!

Ha ha Billy, Lar wasn't that bad lol

Good to have you back man, the board is still going, need to drag a few more peeps away from FB is all. Maybe I'll see you at a meet in WA next year, 2020 is a wash out sadly.
Thanks Seamus, yeah you will see me. Right now im going through my car and cleaning up the wiring and all the little touches. I bought mkiiboostins car and drove it back across the state last weekend. Unfortunately, everything I remember about megasquirt is just about forgot. My biggest hurdle is going to be figuring out what is part of that and what is part if this old alarm system that they put in. I have yet to see the computer for the alarmssystem. But i think its under the foam part of the dash. Anyway, it's good to be back.
 

Registered
Joined
1,206 Posts
Discussion Starter #17
Love when some of the OG's come back and we're like "damn, glad he made it back to the forum, what a tremendous resource he was"...

...and then there's you. Welcome back too I guess.

Hahaha!

--BillyM
Lol, jackass. It's good to hear from you Billy. Jumping into a car with megasquirt you and William where the first two people I thought of. I remember reading your posts with amazement back in the day. Thinking, I will never get there. One question, are all your gauges worthless now? I don't have MPH or a gas gauge and I thought those were mechanical.
 

Registered
Joined
13,114 Posts
I don't run a Megasquirt on anything anymore - all factory Toyota ECU's for me.

...that said, the '98 Aristo motor/trans/ecu means no water temp, oil pressure, rpm, or speedometer at current...

Thank you OBD2!

--billyM
 

Super Moderator
Joined
10,544 Posts
One question, are all your gauges worthless now? I don't have MPH or a gas gauge and I thought those were mechanical.
Speedo is a mechanical cable, should still be there if its an r154 or w58. Disconnected behind the cluster or at the tranny? Gas Gauge doesn't come from the competer either, check if its plugged in, the silver access panel under the hatch board in the hatch. When you peel that off, the thing you are looking at is the fuel sender. Sounds like you inherited some gremlins.
 

Registered
Joined
1,206 Posts
Discussion Starter #20
Speedo is a mechanical cable, should still be there if its an r154 or w58. Disconnected behind the cluster or at the tranny? Gas Gauge doesn't come from the competer either, check if its plugged in, the silver access panel under the hatch board in the hatch. When you peel that off, the thing you are looking at is the fuel sender. Sounds like you inherited some gremlins.
Thanks Seamus, yeah i definitely did. Which is not to say I blame the previous owner, but when I got the car it was like someone got it running on megasquirt and planned to tuck the wires and make it look pretty and everything, but stopped and parked it. I spent yesterday taking out the old alarm system. I figured that the Speedo was probably just not hooked up. I would guess that maybe the sensor for the gas gauge has an issue. I'll check them out. That's my problem is im relearning everything I forgot about these cars. I also have to fix the power steering. I need to either get a stock pump and make it fit with my turbo or go the electric mr2 route.
 
  • Like
Reactions: SupraFiend
1 - 20 of 27 Posts
Top