Toyota Celica Supra Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
22re - fresh rings in and the whole 9, fired up but IDLE stays @ 1500 rpm.
it is my first rebuild and no mech background- very limited knowledge.

what steps could i have missed for this outcome?
some one suggested a vacuum leak, if it is how do i detect the leak?
someone asked if i set the pulley to 0 when i installed the t-chain, could this be the problem?

any links or any of suggestion/help would be greatly appreciated, thank you very much!
 

·
Registered
Joined
·
216 Posts
If your cam timing is correct, then check and make sure your ign timing is correct. Then try and follow ALL vacuum lines to make sure all are hooked up and NONE are leaking or disconnected. if all is well then everything s probably ok, just set the idle screw to lower teh idle and enjoy...
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
MKIIBeater said:
If your cam timing is correct, then check and make sure your ign timing is correct. Then try and follow ALL vacuum lines to make sure all are hooked up and NONE are leaking or disconnected. if all is well then everything s probably ok, just set the idle screw to lower teh idle and enjoy...
where should the idle adjustment screw be set at before all the timing is done? closed off all the way, halfway or.....
 

·
Registered
Joined
·
154 Posts
Hey, I know this is off topic but what are you putting that 22RE into? I am looking at getting either a Toy truck or Runner for the winter. Actually for the winter is what I tell my wife the real reason is I want one real bad. Anyhow I am trying to find out info on the 22R and what upgrades are available.

thanks
 

·
Registered
Joined
·
272 Posts
try checking the throttle linkage... It might not be adjusted right. If it's similar to the Supra one, you can just pop it off the TB. If that fixes the idle, reconnect it and do some adjusting.
 

·
Registered
Joined
·
792 Posts
22RE's are great motors, got one in my '87 truck and have no problems with it. There's a lot of go-fast parts for them, try looking at LC Engineering, DOA Racing engines (got a motor from him a few years ago, the thing is great!), and for really off-the-wall(and waaaay overpriced) parts, Northwest Off-Road. NWOR is great for getting ideas and copying their stuff, but not very good for purchasing.
As for the high idle, try setting your idle lower from the idle screw on the throttle body. If that's not bringing it down, you may have to loosen the tension on the butterfly stop screw, then try the idle screw again.
This should only be done after you check timing is okay and no air leaks.
If you move the butterfly stop screw, you'll have to reset your tps-only after you're happy with the idle and all is good.
Good luck!
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
fellas

awesome fellas :D i appreciate all the help. thank you very much!
 

·
Registered
Joined
·
15 Posts
Discussion Starter #9
suprathepeg said:
Hey, I know this is off topic but what are you putting that 22RE into?
thanks
it is going back into the cel gts fot winter, the boostedwankel will have to hibernate till everything clears up again.

any superchargers for 22re's anyone?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #11
MKIIBeater said:
No but you can get the turbos off of the 22R's from the 4x4 truck's...
more infos PLEASE

thanks :wink:
 
1 - 12 of 12 Posts
Top