Toyota Celica Supra Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
Yet another problem from the 7m swap. My oil pressure guage doesn't work. With the ingnition switch on, the guage goes to MAX. When I start the car, the guage slowly returns all the way down to it's lowest point(below MIN). I wired a light in series at the sender. Lights up with igintion on, goes off when started. The behavior of the light supports what I see at the guage, yes?

What should the sender output when the engine is running and how can it be tested? 89 sender. 85 Supra.

Thanks,

Clark
 

·
Registered
Joined
·
64 Posts
Discussion Starter #3
You da Man

You're exactly right Dave. It hit me last night. Not sure why the Toyota dealer twice sent a digital pressure switch for an 89 7M-GTE motor, but that's what happened. Analog sender going on today.

Did Mark III's have digital dash option, with idiot lights?

At least it only cost me a Sunday afternoon. :)

Clark
 

·
Registered
Joined
·
4,871 Posts
Re: You da Man

5m7m2j said:
You're exactly right Dave. It hit me last night. Not sure why the Toyota dealer twice sent a digital pressure switch for an 89 7M-GTE motor, but that's what happened. Analog sender going on today.

Did Mark III's have digital dash option, with idiot lights?

At least it only cost me a Sunday afternoon. :)

Clark

I don't think so, at least not in 87. Not sure about the later year MKIII's. :roll:
 

·
Registered
Joined
·
9,445 Posts
All,

A digital dash was a option on the RHD JDM MKIII's (I "think" on the GA70's, not sure about the MA70 or the JZA70), but not on any of the LHD cars. Thus the digital dash never made it to North America.

So now I'm wondering why the dealer even has this part??? Unless it was for another digital dash on another model.
 
1 - 5 of 5 Posts
Top