Toyota Celica Supra Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
568 Posts
Discussion Starter · #1 ·
Guys I have developed a intermitent starting fault. The battery is fine and all the connections are fine so I am thinking it is a starter motor problem. It starts most of the time but once in every two or three efforts it just goes clunk.
Anyone got any ideas.
:(
 

·
Registered
Joined
·
1,089 Posts
Sounds like burnt out brushes in your starter motor.
 

·
Registered
Joined
·
733 Posts
This ought to go in a FAQ section. The solenoid connections go bad on these cars. You can renew them yourself, but they are a bit tricky to work on.
 

·
Registered
Joined
·
2,149 Posts
brushes, super easy to fix. It will get worse

will
 

·
Registered
Joined
·
2,149 Posts
I've got one if ya need it... Try the brushes first if that could be the problem it's not only eazy but cheeper too

[email protected]

will
 

·
Registered
Joined
·
568 Posts
Discussion Starter · #7 ·
Will, if the brushes have worn out where do I get the repalcements from?
I have got a contact in Cornwall where I get second hand parts from so I may get one from him. Looks like it a real pain to get at as there not much room in there. Thanks for the offer but I am guessing you are in the US and I am moving house next week so It's better if I don't have any long distance deals going on at the moment.
 

·
Registered
Joined
·
2,149 Posts
Sorry diden't notice you were across the pond :D

The brushes are a standard item your local toyota parts dep should have them. My Step dad owns a auto shop and got them for me but you should be able to find them.

best of luck.

will
 
1 - 8 of 8 Posts
Top