Toyota Celica Supra Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
4,558 Posts
Discussion Starter #1
well, i finally got a new battery and finished reinstalling the coil and distributor, and fired the car up for only the second time since buying it.

OH What a feeling!!

first spin, she started up, and along came a horrible knock.
fairly loud, and seemed timed with the rpms.

could it be a rod?

i shut the engine down pretty much instantly, and i figured it best to post on here before trying again.
is it possibly due to the oil settling?
i tried to spin it over and pre lube the engine, but ive been told not to do it very much on fuel injected cars, or ill likely flood it.

hope someone can tell me its just a simple problem, but im prepaired for the worst (i hope :puppydog: )
 

·
Registered
Joined
·
1,030 Posts
Is it in the top of the engine or the bottom? If its top it could be bad valve knock and you just need to get oil up there..bottom end I dont know.

-Wil
 

·
Registered
Joined
·
4,558 Posts
Discussion Starter #4
i dont remember it making the noise before, but it was also in a very loud environment, so it could have been masked.

nothing has changed, aside from a new distributor, coil, wires and plugs, and no, nothing got in the cylinders while changing the plugs, i checked that.

it sat for about 4 months, but i remember the owner saying something about it making a noise when i bought it, now that i think back.

i think he said his mechanic said something about the camshafts being "broken"... last time i checked, breaking a cam wouldnt let you start the engine, but who knows.
 

·
Super Moderator
Joined
·
8,393 Posts
If the engine hasn't ran in a while spray some light oil into each cylinder. Before you start it, pull the coil wire and crank it at least 30 sec with the gas pedal to the floor. Then try and start it for real. Any knocking noise should go away pretty fast once the oil gets flowing.
 

·
Registered
Joined
·
991 Posts
After sitting for 4 months it certainly could be lack of oil. Mine did that after I let it sit for a month forgetting to start it on a regular basis. Hitting the ignition quickly to preoil shouldn't cause any issues as long as you are doing it every time you start the car. If it is a lack of oil, a quick preoil and you should be able to start it with no noise. If the noise goes away then I would assume that lack of lube was the issue.

Leslie
 

·
Registered
Joined
·
4,558 Posts
Discussion Starter #7
would it be worth draining a couple liters of oil, and pouring new stuff back in to get it mixed around a little?

im not sure if i really want to try cranking it for that long (30 secs+) when its makin a funky noise like that.
 

·
Registered
Joined
·
3,433 Posts
You can prime the oil pump easily by removing the efi fuse and disconnecting the coil wire. If you want to go even easier on the engine you can remove the spark plugs. Then crank the engine over until you see the oil pressure gauge rise (if it still works) the usually the engine is properly lubed.

One way to see if the camshaft is (broken) is to remove the valve cover, unfortunately you won't be able to see how bad the races are. But it might help.
 

·
Registered
Joined
·
174 Posts
if you do remove the spark plugs, plug the plugs back into the wires and touch them to a metal part of the engine to ground them (away from the area between the valve covers, as gasoline vapor will be shooting up from the plug holes when the engine is cranked, that is if the efi fuse is still in there). doing so will prevent damage to your coil.
 

·
Registered
Joined
·
32 Posts
Here is a suggestion

Drain your oil and replace it with new oil and pour in some stuff called "STP oil treatment". This stuff is very thick and thickens up your oil and will make oil stay at the top of the engine when switched off :p . Or falling that put thicker engine oil in. The oil treatment is better, i think!

I did this on my 82 5MGE MA-60, it is perfect now :D !

Good luck :wink: .

Regards
Barnzi
 

·
Registered
Joined
·
4,558 Posts
Discussion Starter #12
yeah, it ran smoothly, for the short time that i ran it, which made me doubt the "cams are broken" lol.

really really nice idle too.

thanks for all the help folks, im going to drain and refill the oil this weekend, then prelube it, then try it again with fingers and toes crossed. :D

wish me luck, i dont wanna swap in my spare engine, lol
 

·
Registered
Joined
·
4,558 Posts
Discussion Starter #13
alright, time to revive this... im stuck in figuring out the noise, and the one mechanic that i could get to come to my home and check it out says he would need to spend a couple hours tearing the engine apart just to find the noise.


are there any people on the boards who are in edmonton or surrounding area, and are good at diagnosing noises.
so far as i can tell, the knock is actually coming from the upper end of the engine.
it doesnt seem to be detonation, or a damaged crank, or a broken cam shaft, but im wondering if it could be piston slap, or a wrist pin, as suprabob suggested.


any help anyone can give will be much appreciated, im stuck, as i can afford to send it out for repairs, but at the moment, i cant afford to have some guy charge me 400 just to diagnose the noise.

so tempting to just tow it to a shop, but again, it starts running into major money really quickly around here. :(

some days... i really wonder why i couldnt have just bought a chevy or a ford like everyone else...
then i look at my car and remember.
 

·
Registered
Joined
·
794 Posts
Ok, take the coil wire out of the coil so the engine wont start and turn it over. Does it knock? Do the same thing with the spark plugs out of the head (so the engine spins faster).

Just for giggles do a compression check while the plugs are out.
 

·
Registered
Joined
·
4,558 Posts
Discussion Starter #15
with the plugs out, it ticks very lightly
and with the plugs in, but no coil and no efi fuse, its about the same volume, considerably lower than when its running.

ive gotta find a good, working compression tester, mine is a bit old, and has never really worked.
 

·
Registered
Joined
·
4,558 Posts
Discussion Starter #17
thanks for the assist :)

my dad came to a similar conclusion after i convinced him that "yes, imports to have lifters"
lol, he was thinking they had some different system, im not sure what, maybe laser guided alien technology or something :?
 
1 - 17 of 17 Posts
Top