Toyota Celica Supra Forum banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
6,116 Posts
Discussion Starter #1
Thought the Overheat prob was gone-Hah!-Monday Afternoon-Stop and go traffic-Boilover-Before it happened I noticed severe detonation-(had stereo off!)After it cooled off it still detonated enough to run hot-car has always run too hot IMO-Tank almost empty-Put bout 2 gallons in tank-Put in a bottle of Techron-First time ive put anything but crappy 87 octane in tank-No Detonation-No boilover-Power there that wasnt before-INJECTORS BAD?-What do yall think?-gonna try crappy 87 octane to see if it will ping again-Is this a good or bad thing that it improved so dramatically?-those of you who have replaced them, what are the MPG/Performance tradeoffs to upgrade?-Thanx Folks- PS-Shows o2 sensor code 21-Intake piping new and tight-Idle speed 650 RPM and steady-No apparent lope or miss-Dont have Timing lite-
 

·
Registered
Joined
·
1,457 Posts
You're either running too much advance on your timing or not putting in enough fuel, or have too high of compression. Check all the hoses, including vacuum, for any leaks. The O2 could be the culprit, but usually won't cause any detonation. If you're getting a code, it would be a good idea to replace it anyways. There's a whole bunch of stuff that could casue this. So check anything related to fuel metering also.

Christian
 

·
Premium Member
Joined
·
6,116 Posts
Discussion Starter #3
I was thinking bad injectors or advanced timing-all vacuum is done-Fuel filter and pump are 2 months old-Run too hot condition predates these-Also Car passed Cal Smog 12/02 and they check timing-Also was thinking Carbon buildup in head-Car did ping slightly on 87 this AM-But nuthin like other day-Hey-Cheap High Compession!!!!-Mike P
 

·
Registered
Joined
·
1,457 Posts
yea, carbon build up could very well cause that. Use a spray bottle and spray a 50/50 mix of water and ATF fluid throught the intake. It's kinda hard to do with an AFM car, but fill up with 91 octane and pop one of the hoses off the plastic intake pipe and just spray in there while idling. That really cleans up the combustion chamber.

Christian
 

·
Registered
Joined
·
1,030 Posts
I always run the 91 octane. I found out the first month the difference it made. Worth a few cents more. The one time I was at a cheapo station with no premium I used 89 and noticed the difference immediately. I also run STP injector cleaner about once every 2 months or so.

Christian are you sure about ATF...I thought carb cleaner?

-Wil
 

·
Premium Member
Joined
·
6,116 Posts
Discussion Starter #6
Alright-Took car last saturday to Shawns house after once again reaching my limits- :mad: after reminding me of Combustion 101, we found no sign of BHG on car-Pulled plugs, and they were toast-So detonation is making heat rise, then long term heat rise/soak like others have described-Leakdown on Cooling system showed leaks-Heres what Ive done-New heater hoses-New paper thermo gasket replacing prvious blue glue-New spark plugs-(NO ONE HAD NGKS DAMMIT :mad: )-New upper and lower rad hoses-At this point-still had long term heat soak-And when I used my heater, temp cooled to normal-AHAH-Shawn says radiator-New Radiator today-YEEHAH :D -Cali Here we come! (Nascar Race) Now I can finally recharge Ac-Mike P
 
1 - 6 of 6 Posts
Top