Toyota Celica Supra Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
I just bought my 85 about a month ago. When i got it the thing was so torquey. I could start out in second gear without and drawbacks. But just recently it lost like half of its power. I can beraly start out in second now and it kinda feels like my fuel filter is bad. When i am driving up a hill it does this weird shakey thing. It will go and hesitate go and hesitate kinda fast but enough to where you go up and down in the seat. What could this be? plugs? fuel filter? maybe even fuel pump?
 

·
Registered
Joined
·
430 Posts
could be the fuel filter.....I would start by doing a complete tuneup on the car....plugs,wires,cap,rotor,fuel filter and see if that helps any


Trybal said:
I just bought my 85 about a month ago. When i got it the thing was so torquey. I could start out in second gear without and drawbacks. But just recently it lost like half of its power. I can beraly start out in second now and it kinda feels like my fuel filter is bad. When i am driving up a hill it does this weird shakey thing. It will go and hesitate go and hesitate kinda fast but enough to where you go up and down in the seat. What could this be? plugs? fuel filter? maybe even fuel pump?
 

·
Registered
Joined
·
792 Posts
you may also wanna try pulling the computer codes to see if something was set.
There's a ton of articles about it here, try searching for ecu codes...
Chris
 

·
Registered
Joined
·
73 Posts
Definitely sounds like the spark plugs are bad. I had all your symptoms and I got new plugs, wires and distributor cap and it runs great (still takes a while to warm up though :( ) but it runs great, nice and strong.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #5
ahhhh anger

I don't think it is the computer.. nothing happened that would of effected it. At least i don't thing. but just in case what do you mean by setting the computer codes? And yeah i am gonna try the plugs and rotor soon.
 
1 - 5 of 5 Posts
Top