Toyota Celica Supra Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
so i've had this problem for a while, and have tried to no avail to fix it...

when i push the car hard, like WOT and bring it up to red, it doesn't want to go....i hit what feels almost like a rev limiter or a fuel cut - off. it doesn't *always* happen but most of the time. usually there is no check engine light associated with it, but one out of A LOT of times there is. i have no real way of checking the codes though cuz i dont got an analog voltmeter :(

anyways, i've done the following to the car:

car is 1983 p type
stock 5mge motor
custom mandrel bent intake
swiss-cheese airbox filled with k&n goodness
straight thru exhaust
electric fan instead of mechanical

this is basically it

i changed the plugs, wires, cap, rotor all about oh say....6 months ago which would be like a good 30,000km (18,000miles for u americans :p)

the o2 sensor was changed about 2 months ago, but the first one i put in was defective and ended up actually somehow "exploding"...i.e. the end cap blew off somehow leaving just the o2 sensor in there with no wire attatched :mad: but oh well got a new one for free

the above listed parts (ignition shit and o2) are all from napa and are all the house brand stuff afaik

the plugs are auto-soemthingorother...copper plugs

i seem to recall trying plat plugs and they didn't work to well so i went back

timing is at 14 degress btdc

*edit*
the fuel filter was changed about a month an a half ago as well
*/edit*

this problem happens with the engine hot, cold, or somewhere in between

my guesses have been the following:

first i thought o2, changed it, still had problem

then i figured it was just needing intake cleaning...did that, car ran faster but still lurched

then i thought ignition, but i had just changed the plugs wires cap and rotor so i figured can't be that

then i figured "oh maybe its mr. ignitor or mrs. coil" so i tested those as per my haynes manual, only to find they seemed fine

i then thought it was my tps, which i have no real way to test becasue i have no feeler gauges AND its confusing as shit to test it, as well as the fact that i don't want to (and can't because this car gets me to and from school and work every day) take it off the car

my only remaining thoughts are that maybe i am not getting the right amount of fuel to the engine...or it is mis-firing due to something

any ideas what is causing this? fuel doesn't seem right cuz it works fine and runs AWESOME at all other speeds, just not after 5400rpm or so

it isn't a constant spot where it happens sometimes, sometimes it'll go into the redline, others it won't make it past 4800...
:(

please help me go faster :p

hehe sorry for the long post but i'm at my wits end with this problem, and i know u guys can help....

*edit*
my other thing is...if this was fuel-related, and i was leaning out up top, would i not hear detonation/pinging really bad? if its ignition and i'm misfiring then it would just not have power at all am i correct?
the other thing is that when i keep my foot on the floor even though it's dieing down and has literally no power, it doesn't usually bounce back with power it sorta bogs down for a second or two OR soemtimes will kinda almost bounce off the "limit" of what i'm hitting
*/edit*
 

·
Premium Member
Joined
·
5,576 Posts
Have you changed fuel filter lately?
 

·
Registered
Joined
·
247 Posts
I second that, definitely check your fuel filter. Just because it runs right at other times doesn't mean the fuel system is okay. Redline is when your car needs the most gas and if the filter is a little clogged it can't get that gas.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #4
my bad, i forgot to mention

the fuel filter was changed about a month an a half ago....

my best guess at this point is the plugs, which i am gonna pull in a little while and see whats up with them

what would my plugs look like if there's been any mis-firing lately?
or does it sound like plugs could do this?
 

·
Registered
Joined
·
43 Posts
Discussion Starter #5
problem solved

installed v-groove ngk plugs one heat range colder, replaced cap, cleaned up rotor

also changed o2 again cuz it broke....so we're done

thanks for the input
 
1 - 5 of 5 Posts
Top