Toyota Celica Supra Forum banner
1 - 6 of 6 Posts

·
Premium Member
'85 Toyota Celica Supra P-Type
Joined
·
223 Posts
Discussion Starter · #1 ·
added more coolant today and tried starting again

will not stay running and not sure if I broke something else

uploading a video to Rumble and will share here:


sent using Tapatalk
 

·
Registered
Joined
·
477 Posts
Was it running with no issues before you did all the work? If so, I would double check all your vacuum lines and intake piping. You may have a vacuum leak somewhere.
 
  • Like
Reactions: JCC

·
Premium Member
'85 Toyota Celica Supra P-Type
Joined
·
223 Posts
Discussion Starter · #3 ·
Was it running with no issues before you did all the work? If so, I would double check all your vacuum lines and intake piping. You may have a vacuum leak somewhere.
yes, it ran great as far as I could tell

will keep digging

come over and I'll bring the barley pop haha

sent using Tapatalk
 

·
Registered
Joined
·
2,110 Posts
fuel starved? and chance you pinched a fuel line? Fuel filter is cheap... Try removing the fuel filter and blowing through it, shoud be fairly eazy to blow through.. also check for "mud" in the filter
 
  • Like
Reactions: JCC

·
Premium Member
'85 Toyota Celica Supra P-Type
Joined
·
223 Posts
Discussion Starter · #5 · (Edited)
very well could be fuel starved

I will need to locate the fuel filter and trace the line

sounds like it is having trouble on the exhaust end also

sent using Tapatalk
 

·
Super Moderator
Joined
·
7,890 Posts
Your Cold Start Injector time switch fucked-up wiring could be part of your start-up issue.
 
  • Like
Reactions: JCC
1 - 6 of 6 Posts
Top