Toyota Celica Supra Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
I finally have my 7M-GTE in the car and running. But am getting codes 24 (air temp sensor) and 31 (mass air flow). The car is running rich. Trying to locate another MAF, but not going well. Before I spend $460 on a new one, I'd like to really make sure the one I've got is bad.

So far, I have tested voltages at VC-Ground, KS-Ground, THA-E2. All appear good except KS-Ground when the engine is running. The voltage stays at 5V as with ignition on. Spec says 2-4V. What concerns me, is that I've got 5V out of the ECU at both VC and KS (when disconnected from the MAF). Isn't KS a square wave OUT of the MAF, to the ECU? Should I be getting 5V FROM the ECU at KS?

Thanks for any info...
 

·
Registered
Joined
·
1,948 Posts
Check on supraforums for a new MAF. Should be a zillion available
after many upgraded to the lexus AFM.

The Karman Vortex does produce a square wave, so it could
very well be thinking it is receving full air at the AFM.

Do you have a stock or aftermarket fuel pump?


5m7m2j said:
I finally have my 7M-GTE in the car and running. But am getting codes 24 (air temp sensor) and 31 (mass air flow). The car is running rich. Trying to locate another MAF, but not going well. Before I spend $460 on a new one, I'd like to really make sure the one I've got is bad.

So far, I have tested voltages at VC-Ground, KS-Ground, THA-E2. All appear good except KS-Ground when the engine is running. The voltage stays at 5V as with ignition on. Spec says 2-4V. What concerns me, is that I've got 5V out of the ECU at both VC and KS (when disconnected from the MAF). Isn't KS a square wave OUT of the MAF, to the ECU? Should I be getting 5V FROM the ECU at KS?

Thanks for any info...
 

·
Registered
Joined
·
501 Posts
i'm not completely sure how to diagnose your problem, but the KS from the ECU should be at 5v without the AFM connected... it's a +5v line from the ecu, the AFM just grounds it/opens it to make the square wave.

but yeah, KS should be +5v from ecu to ground with no sensor connected, and it would be hard to see if it were working properly with a regular multimeter. maybe an analog one might help but it would still be hard to check... if you had access to a scope you'd be money.

if you have some electronics background, you might be able to diagnose it by using a frequency-to-voltage converter (LM2907 at national.com), make somethign and see with an analog meter or a quick response digital one whether the voltage goes up with air flow.

it might make you feel more comfortable spending money on an AFM (i hear they go for between $50 and $150 used) if yours fails further diagnosis, but it might not be worth all the hassle... what else might result in these codes being thrown?

maybe there's a chance that nothing is too wrong with your AFM since you're getting both air temp and afm codes-- u think they're both in the same housing, maybe checking connectors or opening yours up might reveal something obvious? *shrug*

i think there's a reasonably steady demand for used afms, so if you do find a deal on one and you swap it in and the codes don't go away you could probably sell it and make most if not all your money back.

good luck

shiva

5m7m2j said:
I finally have my 7M-GTE in the car and running. But am getting codes 24 (air temp sensor) and 31 (mass air flow). The car is running rich. Trying to locate another MAF, but not going well. Before I spend $460 on a new one, I'd like to really make sure the one I've got is bad.

So far, I have tested voltages at VC-Ground, KS-Ground, THA-E2. All appear good except KS-Ground when the engine is running. The voltage stays at 5V as with ignition on. Spec says 2-4V. What concerns me, is that I've got 5V out of the ECU at both VC and KS (when disconnected from the MAF). Isn't KS a square wave OUT of the MAF, to the ECU? Should I be getting 5V FROM the ECU at KS?

Thanks for any info...
 

·
Registered
Joined
·
64 Posts
Discussion Starter #5
Thanks all. I feel better about the 5v now. Hope to have the MAF connected to a scope this week. As for the Lexus MAF upgrade, Reg's writeup says to use the 7M electronics with the Lexus Body. Has it been shown that the Lexus electronics are functionally identical? If so, I can expand my search :)

Thanks,

Clark
 

·
Registered
Joined
·
501 Posts
i really doubt the electronics here will make a difference. i don't have any first hand experience with it, but i have read about someone using one with lexus electronics. i mean, all it ahs to make as square wave with frequency prop. to the vortex frequency. it's just a matter of a photo transistor grounding or not, the only really important thing that could be different is the high voltage source which your ecu provides anyways and really wouldnt be anything besides 5v unless toyota *completely* changed the design which is unlikely and would have probably resulted in it not-so-subtle differences in running... so if a very small # of people say lexus electronics worked i think it'd be safe to assume you're in teh clear :)

have fun.

shiva
wishing he had a 7m
 

·
Registered
Joined
·
3,247 Posts
ok the maf is the same from the lex and the supra but hears something for you to try go out and buy some contact cleeeener and cleen the flotes in the mas. if you take it off the car and look up at it you will see 2 hoels some times the flote gets gumed up --- like after you oil your fillter with to much oil and it makes the flotes stick giving you a 31 code. so try cleening it first i thought i had a back mas but it just needed to be cleened.
only use electronic contacked cleener!!! Dave
 

·
Super Moderator
Joined
·
8,395 Posts
I've heard of some people saying they've had the Lexus electronics burnout after some use. I'd play it safe and use the MA70 electronics myself.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #10
AFM/MAF Now Working

Thanks for all the advice. I found an air flow meter off a 90-94 LS400 and swapped the electronics. Same part number for the electronics: 22204-42011. And I have a Lexus housing for future 550 injector upgrade. :)

See General Tech if you want to help me diagnose my Oil pressure guage...

Clark
 
1 - 10 of 10 Posts
Top