Toyota Celica Supra Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
My alternator won't charge my battery anymore.
It's the ORIGINAL one, and after 276,000 miles,
I decided to buy a new one to replace it, BUT i can't get
the old one out. I took out the top adjusting bolt,
and the bottom pivoting bolt along with the wires.
but I can't get it out. It just pivots...
So my question is,
Is there a special trick to pulling/installing the Alternator?
please help, It's an '82 5MGE
thanks
 

·
Registered
Joined
·
43 Posts
jhit it iwth mr. hammer

im drunk
but yea
i thsould come right loose or something

yea im drunk

but yea just hit it loose prolly rsuted or coreoed on or something :)

ok fuck...i'll just say TO THE TOP (TTT) with this one

haha
 

·
Registered
Joined
·
1,613 Posts
Uhh... after those words of wisdom... Not sure I can follow up with much more..but I'll try :wink:

If ya have all the bolts out, and its still just pivoting, try tapping it out with a hammer, just make sure ya don;t beat it too badly, or youmay not get your core charge back. You could also try loosening the bolts on the bracket to give you some play there. If that doesn;t work, Try some C-4 High explosive :D ... or not..
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #5 ·
Alright....
I'll give it another try this weekend. It gets dark early,
around 5:00, so i can't after work.
ANYWAY, i'm busy playing Need for Speed: Underground,
and Final Fantasy X-2 AND reading a book. So i'm kinda busy.
But... hammer it is.
Thanks for your help though.
 

·
Registered
Joined
·
43 Posts
HAHAHAHA im drunk again !! LOL


tell me how it sgoes man...i hope it goes well lol

gibsons is good wishkey thats for sure

hahalol

so...mr. alternator come out good? it hosuld with just those too bowlts coming out...cuz thats ho w i did mine...and the belt has to come off (duhhhhhhhhahhhhhh) but yea man.....right on!!

YEA DUDE!
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #7 ·
I'm going to try it Saturday. Like i had said, I've
been busy with work. I Should buy some stands, but
I have to borrow my neighbor's for now. I'm just
switching this now so that i don't kill my battery again
with my stereo. I'm planning to pull the whole engine
apart, but it's gonna be a while.
Anyway, I'll do this tommorrow and give
you guys an update.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #8 ·
Late update, my internet was shut off.
but I changed it and The engine runs alot smoother.
Still overheats though. No oil pressure.
I think i'm supposed to adjust the clearance
of something under the oil pan. I personally haven't
a clue, but a new oil pump is insane at $580!!!
So my wait continues...
Thanks for all of your suggestions though.
 

·
Registered
Joined
·
4,871 Posts
Zean 82 said:
Late update, my internet was shut off.
but I changed it and The engine runs alot smoother.



Who did you choose for a new ISP?? Maybe the wireless network connection performed some voodoo magic on your ECU. :lol:
 

·
Registered
Joined
·
456 Posts
Did you put a new oil pump in? If you have a 82 engine/pan and put a late model pump (aug 84 to 86) pump in then the pickup screen will get mashed down and basically close off the oil supplyu since the 82 pan in approx. 1/2" shallower. You need an early pump to match. There are 2 part numbers.
Price on new pump is approx. $286.00 at local Portland dealer, maybe cheaper thru Jeff Watson at Champion HTH
 

·
Registered
Joined
·
86 Posts
I just bought a new topline oil pump at:

http://www.importperformanceparts.net/

for $166 shipped to Slo town, cali.
It freakin shipped ups ground in 24hrs! :shock:
Me likey import performance parts!
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #12 ·
Let me clarify:
My ISP cut me off cuz we were 3 months behind....Paid it.
I'm using netzero because it's cheap.
And I only Changed the alternator. SOOoo,
now the engine & components have enough power.

There 's barely any oil pressure, so the engine
starts to over heat if it runs(only an idle) for more
than half an hour. The batteries still dead cause its
not getting enough charge time.

I've only checked a couple local stores for prices.
PepBoys doesn't carry it(or just about anything else)
and the shop down the street only has one listing: $580
Most of the sensors should be working though.

Recently before i'd put a new thermostat, timing belt,
and throttle sensor. (Just if you were wondering)
 

·
Registered
Joined
·
999 Posts
asaqwert said:
HAHAHAHA im drunk again !! LOL


tell me how it sgoes man...i hope it goes well lol

gibsons is good wishkey thats for sure

hahalol

so...mr. alternator come out good? it hosuld with just those too bowlts coming out...cuz thats ho w i did mine...and the belt has to come off (duhhhhhhhhahhhhhh) but yea man.....right on!!

YEA DUDE!
:wedrunk:
:rotfl: :rotfl: :rotfl: :rotfl:
 

·
Registered
Joined
·
1,956 Posts
Damn you should have Searched a little more before you changed out your alternator. you could have UPGRADED it to a MKIII turbo one. It has almost 2x the amps and requires VERY little mod. to install it, also it is usually cheaper or roughly the same price as one for an MKII.

I just did it today and was suprised how easy it was.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #15 ·
Sure, now you tell me...
oh well, what's done is done. But anyway
i'm just happy it's working. and if i need
more power one day for my sound system
and neons, etc. i'll upgrade.
Right now i just need good weather and time
to fix the problem with the oil pressure.
 
1 - 15 of 15 Posts
Top