Toyota Celica Supra Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
430 Posts
my car usually runs between 180F and 195F with the turbo. 180 around town and creeps up to 195 around 75-80 and stays there. I would not keep driving if it went any higher. I do have an aftermarket temp guage in my car too. stocker went defunct and damn is the stocker inaccurate :) definatly worth the 35 bucks for the autometer one


_HOT_M16 said:
Stays about straight up and down normal driving, and about 15deg to the right under hard driving.

--billyM
Viva La AutoX!
 

·
Registered
Joined
·
8,423 Posts
Discussion Starter #5
85TurboMKII my car usually runs between 180F and 195F with the turbo. 180 around town and creeps up to 195 around 75-80 and stays there. I would not keep driving if it went any higher. I do have an aftermarket temp guage in my car too. stocker went defunct and damn is the stocker inaccurate :) definatly worth the 35 bucks for the autometer one

Thank you
Now I can get my autometer for about that temp range. Now where to place it?? Are you running half H2o and half anti?? Cuss I need to flush the H2o out anyways so whats the best way to go?? Im thinking of useing the Brown stuff they say its very good??? Anyway thx agean guys. 8)
 

·
Registered
Joined
·
2,297 Posts
I've been using Toyota Red coolant 50/50 mix since the car was new. Never have any cooling problems...ever. The inside of the radiator is always nice and clean. I think it's the best damn coolant on the market, period.
 

·
Registered
Joined
·
430 Posts
I am running half anti/water combination. I mounted my autometer,boost, and A/F guages above my single din radio. they aren't fastened in yet just kind stuck in there but they dont fall out or move any, and it adds to the shadyness of the whole turbo. on the waterneck of the Termo housing there is an allen bolt, I removed the allen bolt and the adapter that came with the autometer temp guage screws in there perfectly. I am using the electric temp guage and it works well.


Thank you
Now I can get my autometer for about that temp range. Now where to place it?? Are you running half H2o and half anti?? Cuss I need to flush the H2o out anyways so whats the best way to go?? Im thinking of useing the Brown stuff they say its very good??? Anyway thx agean guys. 8)
[/quote]
 

·
Registered
Joined
·
53 Posts
85TurboMKII said:
I am running half anti/water combination. I mounted my autometer,boost, and A/F guages above my single din radio. they aren't fastened in yet just kind stuck in there but they dont fall out or move any, and it adds to the shadyness of the whole turbo. on the waterneck of the Termo housing there is an allen bolt, I removed the allen bolt and the adapter that came with the autometer temp guage screws in there perfectly. I am using the electric temp guage and it works well.

Which electric temp gauge are you using? How is it hooked up? I am looking for a new temp gauge as well.

Thanks,
Carlos
 
1 - 9 of 9 Posts
Top