Toyota Celica Supra Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1,089 Posts
Yet another poor soul like myself with and 82 "Vacuume controlled everything!" I swear (and I do ... allot!) that even the signal lights run off of engin vacuume on 82 cars.

Have you checked to make sure that the vacuume advance isn't sticking???

If it was grabing and not advancing as it is suppost to the added vacuum pressure of higher RPMs could cause it to suddenly "POP" into an advanced state at the higher RPM Range. I'm think that would be enough of a power surge to give you a little kick in the pants. :nutkick:

I'd try to clean and inspect the advancing linkage on the distributer and throw a timming light on the engin. if the timming mark does not move between 0 and 1800 rpm and then suddenly jumps then you still got a problem. If not it would be a good idea to clean it anyway 'cause thy tend to stick.

Let us know if this fixes it and if all else fails...:hitit:
 

·
Registered
Joined
·
1,089 Posts
Do you know how to check for intake manifold leaks???

Get a propane torche (like the ones plummers use) and put about 2ft. of rubber hose over the end. DO NOT LIGHT IT! :burn:

let your engine warm up and when it gets a nice slow idle simply pass the propane gas over all the places you think there could be a leak. If there is a leak the propane will raise the idle. Piece of cake ... and a real time saver.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top